Closed Bug 130482 Opened 19 years ago Closed 19 years ago

send link does not work for the second time

Categories

(MailNews Core :: Composition, defect)

x86
Linux
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 82534

People

(Reporter: primorec, Assigned: asa)

References

()

Details

Can I reproduce it ?  YES... always

Steps to reproduce the bug :
A) start fresh new browser
B) go somewhere (for example http://www.mozilla.org)
C) click on menu File
D) click on Send Link ...
E) a Messanger window will pop up .. so far so good
   Cursor is waiting for you to enter e-mail address into To: field
   So far so good
F) close Messanger ___without___ sending the e-mail and without entering
   anything into To: field
G) click again on menu File
I) click on Send Link ... (again)
J) you will not be able to enter the e-mail address inot To: field

BUT 

if you click on Send button and then go back to To: field you will be able
to enter the e-mail address into To: field

WHAT should happen ?
I should be able to enter the e-mail address into To: field regardless
the number of attempts to send the e-mail..


Enviroment:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020310. 
RedHat 6.2
This is not critical.  normal.

worksforme with Linux build 20020309
Repopter, can you still reproduce this?
Yes, any time I choose to...  
here is another way to reproduce a bug:

A) close all mozilla browsers
B) start mozilla
C) go somewhere (for example http://www.mozilla.org)
D) click on "File"
E) click on "Send Link"
F) enter e-mail address into To: field
G) click on "Send" button
H) everything works fine and flawlessly

now

repeat all the steps from D) to H)  again 

result: you will not able to enter the e-mail address into To: field
with keyboard, but you can enter it with mouse "midle" button (paste function)

or

if you click on the Send button (with no address in the To: field) and then
cancel the send process then you will be able to type the e-mail address into
To: field


ok, I see what you're seeing if I actually send the mail.  This behavior would
be fixed by saari's patch in bug 82534.

*** This bug has been marked as a duplicate of 82534 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
it seems to work with the latest incarnation of the mozilla

Mozilla 1.0 Release Candidate 1
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

PLEASE READ THIS:
Yes, this bug is gone...  it is solved 99.99%

A small bug still exist...  

So, here is the desription:
Yes, I can click on "File" and select "Send Link.."
yes, I can send the e-mail

yes, I can send the e-mail for the second time (which was 
the main topic of this bug)

Yes , I can click on To:  and enter the address
Yes, I can click on body and write the message
yes, I can click again on "To:" and enter another address
yes, I can click again on body and continue writing the message

but

I CAN NOT click on URL (which is written in the body)
if I come from "To" field 

and another but

I CAN click at the end of the URL line and move the cursor
back into the URL...  After this action I can click
with a mouse anywhere in the URL

I think this should be fixed as well....
Many times I want to edit the URL , before I send it.

REMAINDER:
URL is a part of the body, because we started the process
with "File --> Send Link..." 
I would imagine that this was actually a dup of bug 130581. If it is indeed the
case that bug 82534 patch fixed it while it existed, it means that bug 82534
should be marked as blocking the bug 137698 (that asks for a proper fix instead
of a workaround for this composition problem).
Component: Browser-General → Composition
Product: Browser → MailNews
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.