pottermore.com/patronus WebGL site never finishes loading in Nightly 52

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: cpeterson, Unassigned)

Tracking

({regression})

unspecified
Unspecified
All
regression
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 unaffected, firefox52- unaffected)

Details

(URL)

(Reporter)

Description

a year ago
[Tracking Requested - why for this release]:

This is a regression in Nightly 52.

@ Jeff: could this be a regression from copyTextImage bug 1290634? I narrowed the regression to this pushlog:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e3608df9fe09f509a8fe62be0cd6743151e4f7a3&tochange=522135225936a32c7b084ba7eea082ee025ea7d5

STR:
1. Load https://my.pottermore.com/patronus
2. Wait 10 seconds for the page to load.

RESULT:
The progress bar moves but the page never loads. I can reproduce the problem on both Windows and Mac.

There are many console warnings about WebGL:

Error: WebGL: texImage2D: Chosen format/type incurred an expensive reformat: 0x1908/0x1401  patronus.js:730:379
Error: WebGL: texImage2D: Incurred CPU-side conversion, which is very slow.
Flags: needinfo?(jgilbert)

Updated

a year ago
Duplicate of this bug: 1304877
Tracking 52+ for this nightly regression.
tracking-firefox52: ? → +
It also doesn't finish loading in Chrome Canary, though the console output is different.
(Both on Win10)

Comment 5

a year ago
I have this on Fedora 24 - it will play in Developer Edition 51.0a2 (2016-09-23) (64-bit in Safe Mode but not in regular mode even with no extensions enabled. Using the version of Firefox that comes with Fedora (currently 49) it will play in Safe Mode but crashes on a segfault in regular mode.
(Reporter)

Updated

a year ago
status-firefox52: --- → affected

Comment 6

a year ago
I just

1. Installed Firefox Stable (49 Linux x86_64) as a non-root user on Fedora 24 x86_64.
2. Ran the browse to the patronus site from the command line. It crashed and put me into a crash report dialog. So it crashes on Mozilla's Firefox as well as Fedora's.

$ ~/FirefoxStable/firefox/firefox https://my.pottermore.com/patronus
ATTENTION: default value of option force_s3tc_enable overridden by environment.
[Parent 7252] WARNING: pipe error (68): Connection reset by peer: file /builds/slave/m-rel-l64-00000000000000000000/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 316
[Parent 7252] WARNING: pipe error (48): Connection reset by peer: file /builds/slave/m-rel-l64-00000000000000000000/build/src/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 316

###!!! [Parent][MessageChannel] Error: (msgtype=0x2C007A,name=PBrowser::Msg_Destroy) Channel error: cannot send/recv

console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
console.warn: nsLoginManager: searchLogins: A `hostname` is recommended
console.warn: nsLoginManager: searchLogins: `formSubmitURL` or `httpRealm` is recommended
1474679175598	addons.webextension.<unknown>	WARN	Loading extension 'null': Reading manifest: Error processing options_ui.open_in_tabs: An unexpected property was found in the WebExtension manifest
1474679175604	addons.webextension.<unknown>	WARN	Loading extension 'null': Reading manifest: Error processing container: An unexpected property was found in the WebExtension manifest.
1474679175604	addons.webextension.<unknown>	WARN	Loading extension 'null': Reading manifest: Error processing api_console_project_id: An unexpected property was found in the WebExtension manifest.
1474679175824	addons.webextension.jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack	WARN	Loading extension 'jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack': Reading manifest: Error processing options_ui.open_in_tabs: An unexpected property was found in the WebExtension manifest
1474679175830	addons.webextension.jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack	WARN	Loading extension 'jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack': Reading manifest: Error processing container: An unexpected property was found in the WebExtension manifest.
1474679175830	addons.webextension.jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack	WARN	Loading extension 'jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack': Reading manifest: Error processing api_console_project_id: An unexpected property was found in the WebExtension manifest.
1474679175847	addons.webextension.jid0-GXjLLfbCoAx0LcltEdFrEkQdQPI@jetpack	WARN	Please specify whether you want browser_style or not in your browser_action options.
ATTENTION: default value of option force_s3tc_enable overridden by environment.
Promise rejected after context unloaded
Promise rejected after context unloaded
tabs.onRemoved event fired after context unloaded.
tabs.onRemoved event fired after context unloaded.
tabs.onUpdated event fired after context unloaded.

I'll go hunt for the crash report it filed ... stay tuned.

Comment 7

a year ago
More testing on Fedora ... with e10s enabled on Nightly 52 in safe mode - site plays the lead-in but never gets to the login prompt.
The site loads fine for me on Win10 with a current Nightly build. Can anyone still reproduce?
Flags: needinfo?(cpeterson)
(Reporter)

Comment 9

a year ago
WFM now in Nightly 52 on Windows 10, though I do still see plenty of WebGL console warnings:

Error: WebGL: texImage2D: Incurred CPU pixel conversion, which is very slow. patronus.js:730:379
Error: WebGL: texImage2D: Chosen format/type incurred an expensive reformat: 0x1908/0x1401 patronus.js:730:379
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(jgilbert)
Flags: needinfo?(cpeterson)
Resolution: --- → WORKSFORME
works for me in nightly 53 and aurora 52 (linux 64bit), removing tracking
status-firefox52: affected → unaffected
tracking-firefox52: + → -
You need to log in before you can comment on or make changes to this bug.