Closed Bug 130496 Opened 20 years ago Closed 20 years ago

Pressing tab at end of line inserts space, tab appears only after continuing to type

Categories

(MailNews Core :: Composition, defect)

x86
Windows 98
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 58712

People

(Reporter: onethreeseven, Assigned: bugzilla)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Pressing tab at the end of a line (any line, not necessarily the end of the
message) inserts a space instead.  Continuing to type then inserts the tab, but
the space remains.  I am in plaintext mode.  Everything behaves if you insert
the tab before the end of the line, and everything is fine in Composer (I
think).  Interestingly, if you press tab twice, you get a space the first time,
then a tab, and you get another tab when you continue typing...

Reproducible: Always
Steps to Reproduce:
1. Begin composing a new message, put yourself at the end of a line
2. Press tab, for a surprise
3. Keep typing, for another surprise

Actual Results:  After you press tab, you get a space.  Once you continue to
type the requested tab appears, but the space remains.

Expected Results:  erm, insert a tab, I suspect...

Bug 126558 (which has been fixed for weeks) involved some confusion between
spaces and tabs (see bug 126558 comment 11), but as I said, it's been fixed for
weeks, and it was a crash bug...
This sounds vaguely like a duplicate of a bug filed against textareas...
grumble.  my second dupe (of two bugs filed) this week.  maybe I need to stop
filing bugs at 2 am.  sorry all

*** This bug has been marked as a duplicate of 58712 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.