Closed Bug 1305193 Opened 3 years ago Closed 3 years ago

Firefox excessively writes "recovery.js" to SSDs every 15 seconds, killing SSD lifespan.

Categories

(Core :: Networking: Cache, defect, major)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1304389

People

(Reporter: arnfranke, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160920074044

Steps to reproduce:

View the SSD I/O disk utilization of Firefox in Resource Monitor as stated in this guide: https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/ Further discussion is at this Reddit thread: https://www.reddit.com/r/pcmasterrace/comments/545rx2/is_anybody_using_firefox_and_has_his_home/


Actual results:

Firefox excessively writes the file "recovery.js" to SSDs every 15 seconds. This can result in 10+ GB of disk writes per day, which vastly lowers SSD lifespan. Further details: https://www.servethehome.com/firefox-is-eating-your-ssd-here-is-how-to-fix-it/


Expected results:

Firefox would ideally automatically detect SSDs and set the "browser.sessionstore.interval" to a disabled value (such as -1 or 0), a high number such as 2 billion, or some other method of disabling writing to the "recovery.js" file.

It has been observed by the author of the linked guide that by changing this value, Firefox only seems to write about 1 GB to the disk per day, which is acceptable.
Severity: normal → major
Another solution would be to change the value "browser.sessionstore.resume_from_crash" to false when an SSD is detected.
Component: Untriaged → Networking: Cache
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1304389
You need to log in before you can comment on or make changes to this bug.