Closed Bug 1305534 Opened 4 years ago Closed 4 years ago

Add debug artifact builds on try

Categories

(Testing :: General, defect)

defect
Not set
normal

Tracking

(firefox52 fixed)

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: armenzg, Assigned: maja_zf)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Right now, debug artifact builds turn out to be non-debug artifact builds.
Does it mean the fix on bug 1253697 was not complete or it regressed lately? Armen which platforms are affected for you?
Btw I just built a debug build locally from mozilla-central latest from earlier today and it all works fine for me on OS X.
Summary: Add debug artifact builds → Add debug artifact builds on try
This is just when using --artifact on try. Right now, this flag always provides and opt artifact build even if your other try syntax specifies debug.
WIP -
Assignee: nobody → mjzffr
https://hg.mozilla.org/try/rev/86f46c36183c61a99c51f127929721ecbf6bc537

This latest try build downloaded the artifact from https://tools.taskcluster.net/task-inspector/#bIFMdGanTXi2900ySTgfdA/, which looks like a debug build, so I think it's working. Now I just have to make debug configs for remaining platforms.
Comment on attachment 8801945 [details]
Bug 1305534 - Add debug artifact builds on try;

https://reviewboard.mozilla.org/r/86526/#review85974

::: browser/config/mozconfigs/linux32/debug-artifact:14
(Diff revision 3)
> +# Needed to enable breakpad in application.ini
> +export MOZILLA_OFFICIAL=1
> +# Enable Telemetry
> +export MOZ_TELEMETRY_REPORTING=1
> +# Package js shell.
> +export MOZ_PACKAGE_JSSHELL=1

These aren't present in the regular artifact mozconfigs... does something fail without them?
Attachment #8801945 - Flags: review?(cmanchester)
Comment on attachment 8801945 [details]
Bug 1305534 - Add debug artifact builds on try;

https://reviewboard.mozilla.org/r/86526/#review85974

> These aren't present in the regular artifact mozconfigs... does something fail without them?

I included these based on what's in debug mozconfigs, but now I've confirmed on try that it's not necessary.
try push with --artifact: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ed83c808b7b5031bd3cd2173607518a829e96fdf
The busted tier-2 builds were there before, not related to this patch.

I am stumped as to why test jobs persistently fail on Windows 7 VM debug -- it seems the tests can't even start the Fx binary. While digging into this, I noticed that the binary uploaded by the --artifact build job (and downloaded by the tests) is not quite the same (checksums, smaller size) as the binary downloaded by the --artifact build job.
Comment on attachment 8801945 [details]
Bug 1305534 - Add debug artifact builds on try;

https://reviewboard.mozilla.org/r/86526/#review88654

I think the issue with those debug tests is that we're not packaging all the necessary dlls. I'll investigate in a follow up.
Attachment #8801945 - Flags: review?(cmanchester) → review+
Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/97db1163c729
Add debug artifact builds on try; r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/97db1163c729
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.