Closed Bug 1305569 Opened 5 years ago Closed 4 years ago

Firefox 48 android uses native useragent instead of general.useragent.override value for icon

Categories

(Firefox for Android Graveyard :: Favicon Handling, defect)

48 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 507641

People

(Reporter: firefox, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36
Build ID: 20160921204512
Firefox for Android

Steps to reproduce:

1. Added string 'General.useragent.override' to about:config, specified an arbitrary value on Android 4.1.2 and Firefox 48
2. Visit your website/web server and watch the server log
3. The last request for the icon from android is using the default user agent(Mozilla/5.0 (Android 4.1.2; Mobile; rv:48.0) Gecko/48.0 Firefox/48.0), instead of what I specified in 1

Please see the server log:

https://paste.debian.net/plain/842391/

HTML code where the logo is specified:

https://paste.debian.net/plain/842392

I'd say general.useragent.override is ignored when FF 48 sees:

< link rel="icon" href="value" / >


Actual results:

Useragent in the server log appears as the arbitrary string specified in 1.

Icon has been downloaded with the default useragent string.


Expected results:

Firefox should use the arbitrary string in general.useragent.override value.
Summary: Firefox 48 android uses native useragent instead of general.useragent.override value → Firefox 48 android uses native useragent instead of general.useragent.override value for icon
Fetching the favicon is done from the Java code rather than using the gecko network stack which is probably why this happens. Not sure if we had a fix for it before and it regressed or if it was always this way.
Component: Untriaged → Favicon Handling
Product: Firefox → Firefox for Android
Sounds like bug 507641.
I guess Kartikaya is right.
I'd makr
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 507641
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.