Closed Bug 1305697 Opened 4 years ago Closed 3 years ago

Missing buttons via www.utest.com homepage

Categories

(Core :: CSS Parsing and Computation, defect, P1)

52 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1308963
Tracking Status
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- disabled
firefox52 --- fixed

People

(Reporter: adalucinet, Assigned: u459114)

References

()

Details

(Keywords: regression, Whiteboard: [webcompat])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20160926030203

Steps to reproduce:

1. Navigate to https://www.utest.com/

Regression range:
Last good revision: 906c1f635c43ca24c685c7d1343d58eb0e4b0baf
First bad revision: bb8f2e88d99176437cdee6f4d50e6c5cd6a91f60
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=906c1f635c43ca24c685c7d1343d58eb0e4b0baf&tochange=bb8f2e88d99176437cdee6f4d50e6c5cd6a91f60

Looks like the following bug has the changes which introduced the regression:
https://bugzil.la/1294660



Actual results:

'Join as a lite user' and 'Join as a full user' buttons are missing.


Expected results:

The buttons are properly displayed.
Blocks: 1294660
Keywords: regression
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
Chrome Dev 55.0.2859.0 is also affected.

Seems the site problem.
Unfortunately, I'm not able to reproduce with latest available Chrome version (53.0.2785.116) for OS X 10.11.6 - http://imgur.com/IcWXpv2
Reproducible
Version 	52.0a1
Build ID 	20160930030315
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:52.0) Gecko/20100101 Firefox/52.0
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Form Controls
Ever confirmed: true
Product: Firefox → Core
This is the same issue as bug 1301106 which we saw on Twitter.

I again think we should consider asking the spec to change given we are seeing more broken sites with that spec, especially given that WebKit and Blink have no plan to change their current behavior.

If people think the spec should keep as-is, we should file bugs to other engines to push them to align with the spec, rather than spend time asking each single site to fix over and over again.
Component: Layout: Form Controls → CSS Parsing and Computation
OS: Mac OS X → All
Yeah.

Blink implemented the no-repeat (-webkit-)mask-repeat default value in https://bugs.chromium.org/p/chromium/issues/detail?id=628968, but it was reverted according to comment 11 of that bug due to https://bugs.chromium.org/p/chromium/issues/detail?id=645000.

So they reverted due to Twitter CSS (which has since been updated). I've asked for an update in their bug tracker... but my gut feeling is we should probably ask the spec to change for webcompat given that two engines are running into bugs.
Whiteboard: [webcompat]
Depends on: 1308963
Assignee: nobody → cku
CJ, is there any additional effort needed after bug 1308963 is resolved ? If not, probably we should set this bug as dup of bug 1308963.
Flags: needinfo?(cku)
Fixed along with bug 1308963. Set dup.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(cku)
Resolution: --- → DUPLICATE
Duplicate of bug: 1308963
Hi :adalucinet, 
Since bug 1308963 was fixed, could you help verify if this issue is fixed as expected on the latest Nightly build? Thanks!
Flags: needinfo?(adalucin)
In bug 1294660, mask-image only enabled on nightly and aurora. Therefore, no need to uplift the fix in bug 1308963 to FF51 aurora since the symptom will be gone when FF51 goes to beta.

Mark flag status-firefox51 to disabled.
Per comment #9, no need to verify it. Clear ni.
Flags: needinfo?(adalucin)
You need to log in before you can comment on or make changes to this bug.