Title truncation breaks multi-byte characters

RESOLVED DUPLICATE of bug 898984

Status

()

RESOLVED DUPLICATE of bug 898984
2 years ago
2 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8795338 [details]
firefox_multi_byte_title_bug_demo.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160919004008

Steps to reproduce:

Place a multi-byte Unicode character in the <title> tag


Actual results:

When there's enough space to display the full title, the character is correctly displayed.
When there's not enough space, (under certain conditions, depending on the available space) some of the character's bytes are cut off and it does not display correctly.


Expected results:

The character should either not be removed or entirely.
(Reporter)

Comment 1

2 years ago
You may have to adjust the demo's encoding via View -> Text Encoding -> Unicode because bugzilla uses windows-1252 ...
(Reporter)

Comment 2

2 years ago
Created attachment 8795340 [details]
firefox_multi_byte_title_bug.png

Updated

2 years ago
Component: Untriaged → Tabbed Browser

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898984
You need to log in before you can comment on or make changes to this bug.