Outline changes size with mouse movement in animation

RESOLVED DUPLICATE of bug 1305976

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1305976
2 years ago
2 years ago

People

(Reporter: adamopenweb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webcompat], URL)

(Reporter)

Description

2 years ago
This bug was originally reported on webcompat.com anonymously: https://webcompat.com/issues/3297

STR:
1) Navigate to: https://jsfiddle.net/h7gpxc4w/
2) Move mouse around

Expected Behavior:
Outline property width on row is consistent even with non attached mouse movement

Actual Behavior:
On Firefox, if I move the mouse then the outline width changes in animation. In Chrome it is consistent.

I am able to reproduce this in Firefox 49 and 52 on OSX and Windows 10.
(Reporter)

Updated

2 years ago
Whiteboard: [webcompat]
Looks like our outline size depends on the content, and transform happens in compositor thread so the outline size is not updated properly during animation?

I guess we can probably change the outline impl to not depending on the content, so that its size would be consistent across repaint. If this isn't breaking any real site, I don't think it has a high priority, though.
Given there are more discussion in bug 1305976, duplicate this one into that.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1305976
You need to log in before you can comment on or make changes to this bug.