Closed Bug 1305959 Opened 3 years ago Closed 3 years ago

[Static Analysis][Uninitialized scalar field] In constructor ClientNavigateRunnable

Categories

(Core :: DOM: Service Workers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: paul.bignier, Assigned: paul.bignier)

References

(Blocks 1 open bug)

Details

(Keywords: coverity, Whiteboard: [CID 1368348])

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160921132349
Keywords: coverity
Product: Firefox → Core
Whiteboard: [CID 1368348]
* Run() seems to be the initializer but it can exit early so need to initiliaze to square with the coming MOZ_ASSERT(mWorkerPrivate);
Hi Johnny,
Could you please route this patch to the concerned person? I'm not sure who it is and all the dom/workers/ peers are tagged as "not receiving bugmail".
Thank you,
Paul
Flags: needinfo?(jst)
Component: Untriaged → DOM: Service Workers
Comment on attachment 8795672 [details] [diff] [review]
Initialize a ClientNavigateRunnable  member

Ben Kelly (:bkelly) would probably be the best person to look at this, though he's out this week is looks like, so baku can hopefully help sooner.
Flags: needinfo?(jst)
Attachment #8795672 - Flags: review?(amarchesini)
Comment on attachment 8795672 [details] [diff] [review]
Initialize a ClientNavigateRunnable  member

Review of attachment 8795672 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/workers/ServiceWorkerWindowClient.cpp
@@ +335,5 @@
>                           PromiseWorkerProxy* aPromiseProxy)
>      : mWindowId(aWindowId)
>      , mUrl(aUrl)
>      , mPromiseProxy(aPromiseProxy)
> +    , mWorkerPrivate()

, mWorkerPrivate(nullptr)
Attachment #8795672 - Flags: review?(amarchesini)
Attachment #8796062 - Flags: review?(amarchesini)
Attachment #8795672 - Attachment is obsolete: true
Attachment #8796062 - Flags: review?(amarchesini) → review+
Assignee: nobody → paul.bignier
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f10953ecc7ab
Initialize a ClientNavigateRunnable member. r=baku
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f10953ecc7ab
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.