[10.12] Web notification popups no longer work after upgrading to macOS Sierra

RESOLVED INVALID

Status

()

Toolkit
Notifications and Alerts
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

unspecified
Unspecified
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(firefox49 affected, firefox50 affected, firefox51 affected, firefox52 affected)

Details

(URL)

(Reporter)

Description

a year ago
STR:
1. On macOS 10.12, load http://www.bennish.net/web-notifications.html
2. Click "Authorize" button.
3. Click "Show" button.

RESULT:
Nothing happens on macOS 10.12. This notification test works correctly in Chrome on macOS 10.12 and in Firefox on macOS 10.11.
This is working correctly for me on 10.12 with Nightly.
(Reporter)

Comment 2

a year ago
It doesn't work for me in Firefox 49 or Nightly 52 in a new profile. Maybe I have disabled something in my system settings, but I don't see any non-default settings in the System Preferences > Notifications page.

Strangely, I don't see Chrome in the list of apps using notifications. Maybe Chrome uses a different notification mechanism.
(Reporter)

Comment 3

a year ago
I first noticed this problem because my IRCCloud web client stopped showing notifications when people were trying to ping me on IRC.
Kit, can you take a look?
Flags: needinfo?(kcambridge)
Hmm, notifications show up for me on 49.0.1 and 52.0a1 on Sierra. Chris, would you mind running this in the Browser Console and reporting if you get one?

    Cc["@mozilla.org/system-alerts-service;1"].getService(Ci.nsIAlertsService).showAlertNotification("https://tests.peter.sh/resources/large-cat.jpg", "Notification title", "Some text", true);

Do the notifications show up in Notification Center at all?
Flags: needinfo?(kcambridge) → needinfo?(cpeterson)
(Chrome uses their own notification mechanism, but you can try using system notifications by flipping chrome://flags/#enable-native-notifications).

Comment 7

a year ago
I also could not reproduce the issue on Mac 10.12, Nightly 52.0a1.
(Reporter)

Comment 8

a year ago
This was (my) user error. Sorry for the false alarm.

I had disabled the NotificationCenter service a long time ago (because I was annoyed from other apps' notifications). I don't know why I didn't realize earlier that I wasn't receiving IRCCloud ping notifications.

http://osxdaily.com/2012/08/06/disable-notification-center-remove-menu-bar-icon-os-x/
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(cpeterson)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.