border-style not maintained with border-radius

RESOLVED DUPLICATE of bug 382721

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 382721
9 months ago
9 months ago

People

(Reporter: Martijn, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

A border-style of anything but solid, so dotted for example, becomes solid in the curved part of an element with border radius.

Example: https://jsfiddle.net/oxr51opa/


Actual results:

On an element with border-style:dotted and border-radius:50%, the border looks completely solid. border-width appears to make no difference either.


Expected results:

Should look dotted, just like on Chrome and Edge.

Updated

9 months ago
Component: Untriaged → Layout
Product: Firefox → Core

Comment 1

9 months ago
It's fixed in the next release (v50).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 382721
You need to log in before you can comment on or make changes to this bug.