Add telemetry probe for when printing is initiated

RESOLVED FIXED in Firefox 50

Status

()

P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mlongaray, Assigned: thaua)

Tracking

unspecified
mozilla52
Points:
---

Firefox Tracking Flags

(firefox50 fixed, firefox51 fixed, firefox52 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.116 Safari/537.36

Steps to reproduce:

I spoke to Mike Conley and laid out that we are still missing yet another telemetry probe.

1) When the user prints a document. This is a keyed histogram, with the following keys: printed from outside print preview, printed from within print preview, and printed a simplified document. Probe was landed in bug 1287587.
2) The user enters print preview. This is a normal count histogram, and was landed in bug 1275570.
3) The user simplifies a print preview. This is a normal count histogram, and was landed in bug 1275570.
4) The user enters print preview, but simplification is deemed not possible. Normal count histogram that was landed in bug 1287587.
5) When the user initiates a print operation. This is a keyed histogram, with the following keys: printing from outside print preview, and printing from within print preview.

So this bug is basically about adding (5).
(Reporter)

Updated

2 years ago
Component: Untriaged → Printing
Product: Firefox → Toolkit
Assignee: nobody → thaua
Priority: -- → P2
(Assignee)

Comment 1

2 years ago
Created attachment 8796685 [details] [diff] [review]
WIP1: Add telemetry probe

This patch adds new telemetry probe that counts when the user opens print dialog.
Attachment #8796685 - Flags: review?(mconley)
Comment on attachment 8796685 [details] [diff] [review]
WIP1: Add telemetry probe

Review of attachment 8796685 [details] [diff] [review]:
-----------------------------------------------------------------

This looks okay to me, but going to request data-review from liuche.

::: toolkit/components/telemetry/Histograms.json
@@ +6262,5 @@
> +     "kind": "count",
> +     "keyed": true,
> +     "releaseChannelCollection": "opt-out",
> +     "description": "A counter incremented every time the user opens print dialog."
> +   },

Busted indentation here.
Attachment #8796685 - Flags: review?(liuche)
Comment on attachment 8796685 [details] [diff] [review]
WIP1: Add telemetry probe

Review of attachment 8796685 [details] [diff] [review]:
-----------------------------------------------------------------

Data-review only. This looks fine to me - it describes when this probe is measured, which is every time the print dialog is opened.
Attachment #8796685 - Flags: review?(liuche) → review+
(Assignee)

Comment 4

2 years ago
Created attachment 8798026 [details] [diff] [review]
WIP2: Fix indentation

Small change as mconley suggested.
Attachment #8796685 - Attachment is obsolete: true
Attachment #8796685 - Flags: review?(mconley)
Attachment #8798026 - Flags: review?(mconley)
Comment on attachment 8798026 [details] [diff] [review]
WIP2: Fix indentation

Review of attachment 8798026 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!
Attachment #8798026 - Flags: review?(mconley) → review+
Author: Thauã Silveira <thaua@hp.com>
Bug number: 1306624
Commit message:

"Bug 1306624 - Add telemetry probes to count how many times a user requests to print a document. r=mconley, data-review=liuche

This is distinct from the PRINT_COUNT probe, which counts how many times Gecko starts a print operation (which might not occur if the user cancels out of the print dialog)."
Keywords: checkin-needed

Comment 7

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1ee5506cde86
Add telemetry probes to count how many times a user requests to print a document. r=mconley, data-review=liuche
Keywords: checkin-needed

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1ee5506cde86
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
(Reporter)

Comment 9

2 years ago
Hey Mike, are we planning to uplift this one to Aurora & Beta as well?
Flags: needinfo?(mconley)
Yes, I believe that makes sense.
Flags: needinfo?(mconley)
Comment on attachment 8798026 [details] [diff] [review]
WIP2: Fix indentation

Approval Request Comment
[Feature/regressing bug #]:

Printing.

[User impact if declined]:

None.

[Describe test coverage new/current, TreeHerder]:

None.

[Risks and why]: 

Very low. This just adds a Telemetry probe that counts how many times the print dialog is displayed to the user. liuche did the data review.

[String/UUID change made/needed]:

None.
Attachment #8798026 - Flags: approval-mozilla-beta?
Attachment #8798026 - Flags: approval-mozilla-aurora?

Updated

2 years ago
status-firefox50: --- → affected
status-firefox51: --- → affected
Comment on attachment 8798026 [details] [diff] [review]
WIP2: Fix indentation

This seems like a good telemetry probe to add. Aurora51+, Beta50+
Attachment #8798026 - Flags: approval-mozilla-beta?
Attachment #8798026 - Flags: approval-mozilla-beta+
Attachment #8798026 - Flags: approval-mozilla-aurora?
Attachment #8798026 - Flags: approval-mozilla-aurora+
Hi Mike, going forward, for such uplifts, could you please mention whether we have verified that data is showing up on Nightly channel on the new probe and looks good? This help decide whether uplifting it is a good idea or not.
Flags: needinfo?(mconley)
I checked the evo dashboard and on Nightly52, there have been submissions on PRINT_DIALOG_OPENED_COUNT probe since Oct 11th so we are good.

Comment 15

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/684b31fa5cb1
status-firefox51: affected → fixed

Comment 16

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/a7106084ad63
status-firefox50: affected → fixed
(In reply to Ritu Kothari (:ritu) from comment #13)
> Hi Mike, going forward, for such uplifts, could you please mention whether
> we have verified that data is showing up on Nightly channel on the new probe
> and looks good? This help decide whether uplifting it is a good idea or not.

Will do! Thanks!
Flags: needinfo?(mconley)
You need to log in before you can comment on or make changes to this bug.