Closed Bug 1306714 Opened 3 years ago Closed 3 years ago

Implement RFC 7983 when demuxing DTLS

Categories

(Core :: WebRTC: Networking, defect, P2)

52 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed
Blocking Flags:

People

(Reporter: drno, Assigned: drno)

References

Details

Attachments

(1 file)

Our RTP and RTCP receivers already inspect the first byte of received packets to filter out packets which are not RTP/RTCP.
Per RFC 7983 we should do the same for DTLS. This should save a few cycles when a PC uses data channel and RTP at the same time.
backlog: --- → webrtc/webaudio+
Rank: 25
Priority: -- → P2
Attachment #8796691 - Flags: review?(ekr) → review?(martin.thomson)
Comment on attachment 8796691 [details]
Bug 1306714: Use RFC 7983 detection for DTLS packets.

https://reviewboard.mozilla.org/r/82456/#review87492
Attachment #8796691 - Flags: review?(martin.thomson) → review+
Pushed by drno@ohlmeier.org:
https://hg.mozilla.org/integration/autoland/rev/ef16dca83272
Use RFC 7983 detection for DTLS packets. r=mt
https://hg.mozilla.org/mozilla-central/rev/ef16dca83272
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Duplicate of this bug: 1279175
You need to log in before you can comment on or make changes to this bug.