Closed Bug 1306953 Opened 3 years ago Closed 3 years ago

Firefox49 showing graphics artifacts with HWA enabled on Intel GMA 3600

Categories

(Core :: Graphics, defect)

49 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1306465
Tracking Status
platform-rel --- -
firefox49 --- fixed
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: nthomas, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [gfx-noted][platform-rel-Intel])

Attachments

(2 files)

Attached image graphics artifacts.png
This is a lot like bug 1304360, except for the Intel GMA 3600 in an Atom-based netbook my parents have. The Device ID (0x0be1) doesn't appear in the list of devices in widget/GfxDriverInfo.cpp, so I'm not sure if attachment 8794983 [details] [diff] [review] will help.

STR:
1, Use Firefox 49.0.1 on a HP XX netbook
2, Open http://www.nzherald.co.nz
3, Scroll down and see artifacts (see attachment)

Reverting to 48.0.2 solves the problem, so does disabling hardware acceleration in the advanced preferences.
Attached file about:support
gw280, could you confirm this is similar case of a buggy D3D9 fallback ?  Unfortunately I won't have access to this machine very soon, so won't be able to verify any settings or run test builds from bug 1306689.
Flags: needinfo?(gwright)
Keywords: regression
Whiteboard: [gfx-noted]
Nick, when you do get a hold of this machine, could you check if setting layers.allow-d3d9-fallback in about:support to false (and restarting) make the problem go away?
Flags: needinfo?(gwright)
Version: Trunk → 49 Branch
Flags: needinfo?(milan)
Assuming this affects the versions between 49 and 52 as well
platform-rel: --- → ?
Whiteboard: [gfx-noted] → [gfx-noted][platform-rel-Intel]
I've asked my parents to try flipping that pref.
Flags: needinfo?(nthomas)
They've confirmed that flipping layers.allow-d3d9-fallback to false works (with 'Use hardware acceleration when available' ticked).
Flags: needinfo?(nthomas)
That would suggest the patch in bug 1306465 should take care of this.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(milan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1306465
(Removing the regression keyword since it's on the dupe (now))
Keywords: regression
Sorry, should have just made the tracking flags match rather than removing the regression keyword.
You need to log in before you can comment on or make changes to this bug.