Display the offset-parent in the box-model panel

RESOLVED DUPLICATE of bug 1291417

Status

()

Firefox
Developer Tools: Computed Styles Inspector
RESOLVED DUPLICATE of bug 1291417
2 years ago
2 years ago

People

(Reporter: jdescottes, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox52 affected)

Details

Attachments

(1 attachment)

When debugging the layout of absolutely or relatively positioned elements, I often find myself hunting the offset parent by climbing up the parent nodes and waiting to find the first positioned element.

It could be nice to add this information in the box-model panel of the "computed" tab. The offset parent could be identified by a CSS selector, and accompanied with a button to select it in the markup view.
Created attachment 8797108 [details]
offset-parent-boxmodel.png
I think this is a dupe of bug 1291417 (part of meta bug 1150496).
It'd be nice to do the same thing for block formatting contexts and floated elements, and for stacking contexts and z-index elements.
(In reply to Patrick Brosset <:pbro> from comment #2)
> I think this is a dupe of bug 1291417 (part of meta bug 1150496).

Yes, it is. Did not find it searching through bugzilla and for once I thought I'd open without asking before.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1291417
You need to log in before you can comment on or make changes to this bug.