cookies.js relies on AppConstants but is used from cookies.xul which does not import it at any point

RESOLVED FIXED in Firefox 51

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

({regression})

51 Branch
Firefox 52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51+ fixed, firefox52 fixed)

Details

Attachments

(1 attachment)

Noticed on my nightly build that if you open the cookies dialog and hit a key, you get:

JavaScript error: chrome://browser/content/preferences/cookies.js, line 762: ReferenceError: AppConstants is not defined

This looks like a regression from bug 1294989
[Tracking Requested - why for this release]: regression introduced in v51
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Comment on attachment 8797193 [details]
Bug 1307132 - import AppConstants.jsm,

https://reviewboard.mozilla.org/r/82792/#review82520
Attachment #8797193 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/3ee1fa4da71b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Track 51+ as regression.
Hi :Gijs,
Since this bug is a regression and also affects 51, do you consider to uplift this for 51?
Flags: needinfo?(gijskruitbosch+bugs)
Comment on attachment 8797193 [details]
Bug 1307132 - import AppConstants.jsm,

Approval Request Comment
[Feature/regressing bug #]: bug 1294989
[User impact if declined]: parts of the preferences' cookies dialog don't work correctly.
[Describe test coverage new/current, TreeHerder]: noooope, or we would have noticed earlier. I think the cookies dialog itself does have tests, just not once that noticed this breakage.
[Risks and why]: very low, effectively a 1-liner.
[String/UUID change made/needed]: nope
Flags: needinfo?(gijskruitbosch+bugs)
Attachment #8797193 - Flags: approval-mozilla-aurora?
Comment on attachment 8797193 [details]
Bug 1307132 - import AppConstants.jsm,

Fix a regression. Take it in 51 aurora.
Attachment #8797193 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.