Stop writing PYTHON_UNIT_TESTS to backend.mk

RESOLVED DUPLICATE of bug 1317970

Status

RESOLVED DUPLICATE of bug 1317970
2 years ago
8 months ago

People

(Reporter: ahal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
In bug 1304593 I modified make check to run |mach python-tests| instead of iterating over directories and running each file in PYTHON_UNIT_TESTS directly. This means that PYTHON_UNIT_TESTS in backend.mk files are no longer needed.

I believe this gets generated somewhere in recursivemake.py:
https://dxr.mozilla.org/mozilla-central/source/python/mozbuild/mozbuild/backend/recursivemake.py
(Reporter)

Comment 1

2 years ago
I believe this got fixed as a side effect of bug 1317970.. at least I no longer see PYTHON_UNIT_TESTS anywhere in backend.mk files.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1317970

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.