mozilla crashes when loading gif on linux/alpha

RESOLVED DUPLICATE of bug 127455

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 127455
17 years ago
17 years ago

People

(Reporter: blizzard, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
http://images.slashdot.org/banner/sfos0783en.gif

If you load this image on a linux/alpha system it will crash.  This is a 0.9.9
build.
(Reporter)

Comment 1

17 years ago
[17:19:38] <Sopwith> #0  0x20001bc1a0c in nsImageGTK::DrawToImage () from
/usr/lib/mozilla/components/libgfx_gtk.so
[17:19:38] <Sopwith> #1  0x20002be4954 in gfxImageFrame::DrawTo () from
/usr/lib/mozilla/components/libgfx2.so
[17:19:38] <Sopwith> #2  0x20001b6c518 in imgContainer::AppendFrame () from
/usr/lib/mozilla/components/libimglib2.so
[17:19:38] <Sopwith> #3  0x20002bd02ac in HaveDecodedRow () from
/usr/lib/mozilla/components/libimggif.so
[17:19:38] <Sopwith> #4  0x20002bcdb04 in output_row () from
/usr/lib/mozilla/components/libimggif.so
[17:19:38] <Sopwith> #5  0x20002bce018 in do_lzw () from
/usr/lib/mozilla/components/libimggif.so
[17:19:40] <Sopwith> #6  0x20002bce4fc in gif_write () from
/usr/lib/mozilla/components/libimggif.so
(Reporter)

Comment 2

17 years ago
tor, this might be your bug.
(Assignee)

Comment 3

17 years ago
or rjesup
(Reporter)

Comment 4

17 years ago
FYI, Elliot is trying to get line numbers for me so we can get a better stack
trace here.
This is almost CERTAINLY a dup of 127455, which has a patch and an sr=tor, just
needs an r= and I'll ask for a=.  Any takers?

*** This bug has been marked as a duplicate of 127455 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.