Closed Bug 1307358 Opened 4 years ago Closed 4 years ago

beta doesnt build using --with-system-icu

Categories

(Firefox Build System :: General, defect)

50 Branch
All
OpenBSD
defect
Not set

Tracking

(firefox50 fixed, firefox51 fixed, firefox52 fixed)

VERIFIED FIXED
mozilla52
Tracking Status
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: gaston, Assigned: xidorn)

References

Details

Attachments

(1 file, 1 obsolete file)

On OpenBSD, using --with-system-icu, beta (1 and 3) fail to build on:

In file included from /home/obj/ports/firefox-50.0beta3/build-amd64/netwerk/dns/Unified_cpp_netwerk_dns0.cpp:65:
In file included from /home/obj/ports/firefox-50.0beta3/firefox-50.0b3/netwerk/dns/nsIDNService.cpp:6:
/home/obj/ports/firefox-50.0beta3/firefox-50.0b3/netwerk/dns/nsIDNService.h:16:10: fatal error: 'unicode/uidna.h' file not found
#include "unicode/uidna.h"


unicode/uidna.h is in /usr/local/include but -I/usr/local/include is not present in the build flags for Unified_cpp_netwerk_dns0.cpp - so probably a missing MOZ_ICU_CFLAGS somewhere. Here's what i have in config.status:

    "MOZ_ICU_CFLAGS": [
        "-I/usr/local/include"
    ],
    "MOZ_ICU_LIBS": [
        "-L/usr/local/lib",
        "-licui18n",
        "-licuuc",
        "-licudata"
    ],
Another possibility is that uidna.h isnt created under system_wrappers/unicode which should also wrap it ?
Flags: needinfo?(mh+mozilla)
This might be regression by bug 1284406.
Trying with unicode/uidna.h added to config/system-headers...
(In reply to Makoto Kato [:m_kato] from comment #2)
> This might be regression by bug 1284406.

Oh, probably then - thanks, hadnt found this bug.
Flags: needinfo?(mh+mozilla)
Fails also with unicode/uidna.h added to config/system-headers:

/home/obj/ports/firefox-50.0beta3/build-amd64/dist/system_wrappers/unicode/uidna.h:3:15: fatal error: 'unicode/uidna.h' file not found
#include_next <unicode/uidna.h>
Blocks: 1284406
Attached patch patch (obsolete) — Splinter Review
Could you test if this patch works for you?
Flags: needinfo?(landry)
Attachment #8797448 - Flags: review?(mh+mozilla)
Yep, works for me - once commited, would need backporting to aurora and beta, ideally.....
Flags: needinfo?(landry)
Comment on attachment 8797448 [details] [diff] [review]
patch

Review of attachment 8797448 [details] [diff] [review]:
-----------------------------------------------------------------

::: old-configure.in
@@ +5783,5 @@
> +if test "$MOZ_WIDGET_TOOLKIT" = "cocoa"; then
> +    USE_ICU=1
> +fi
> +
> +MOZ_CONFIG_ICU()

It would probably be better moved above
https://dxr.mozilla.org/mozilla-central/rev/42c95d88aaaa7c2eca1d278399421d437441ac4d/old-configure.in#5736

Likewise in js/src/old-configure.in.
Attachment #8797448 - Flags: review?(mh+mozilla) → feedback+
Comment on attachment 8797919 [details]
Bug 1307358 - Config ICU before assigning OS_*FLAGS.

https://reviewboard.mozilla.org/r/83516/#review82128
Attachment #8797919 - Flags: review?(mh+mozilla) → review+
Attachment #8797448 - Attachment is obsolete: true
Assignee: nobody → xidorn+moz
Keywords: checkin-needed
Comment on attachment 8797919 [details]
Bug 1307358 - Config ICU before assigning OS_*FLAGS.

Approval Request Comment
[Feature/regressing bug #]: bug 1284406
[User impact if declined]: Package maintainers for distributions may not be able to build Firefox
[Describe test coverage new/current, TreeHerder]: Build system only change, should be fine as far as it doesn't bust on TreeHerder
[Risks and why]: low risk as far as it builds
[String/UUID change made/needed]: n/a
Attachment #8797919 - Flags: approval-mozilla-beta?
Attachment #8797919 - Flags: approval-mozilla-aurora?
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/890556340d6e
Config ICU before assigning OS_*FLAGS. r=glandium
Keywords: checkin-needed
Comment on attachment 8797919 [details]
Bug 1307358 - Config ICU before assigning OS_*FLAGS.

Fix to support distro builds, Aurora51+, Beta50+
Attachment #8797919 - Flags: approval-mozilla-beta?
Attachment #8797919 - Flags: approval-mozilla-beta+
Attachment #8797919 - Flags: approval-mozilla-aurora?
Attachment #8797919 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/890556340d6e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
50beta5 built fine using --with-system-icu.
Status: RESOLVED → VERIFIED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.