Add `shape-margin` support to the style system

RESOLVED DUPLICATE of bug 1265342

Status

()

Core
CSS Parsing and Computation
P3
normal
RESOLVED DUPLICATE of bug 1265342
2 years ago
3 months ago

People

(Reporter: Tommy Kuo (away forever...), Assigned: bradwerth)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
I'd like to implement `shape-margin` property in style system.
Blocks: 1265342
Summary: Add `shape-maring` support to the style system → Add `shape-margin` support to the style system
Could you please clarify how this differs from bug 1265342?

Sebastian
Flags: needinfo?(kuoe0)
(Reporter)

Comment 2

2 years ago
In this bug, I'll only add the CSS property into style system. The rendering part I think we should wait `shape-outside` finished.
Flags: needinfo?(kuoe0)
Ah, I see. Then please don't forget to put the property behind the layout.css.shape-outside.enabled preference, so it's not exposed to web content by default.

Sebastian
(Reporter)

Comment 4

2 years ago
Ok, no problem!

Updated

2 years ago
Priority: -- → P3
Adding this CSS property looks so trivial that I don't think it's worth being done in a separate bug, especially given you do not plan to finish the layout part soonish.

Also, adding parser support for things we do not actually support in layout would add extra burden as we may need a separate pref to control its exposing if we decide to expose e.g. shape-outside by default without support of shape-margin. And that usually also adds more documentation work with no good reason, and that could even confuse developers.
(Assignee)

Comment 6

4 months ago
I'll try to move this forward.
Assignee: kuoe0.tw → bwerth
(Assignee)

Comment 7

3 months ago
This will be resolved as part of the implementation, in Bug 1265342.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1265342
You need to log in before you can comment on or make changes to this bug.