Closed Bug 1307645 Opened 3 years ago Closed 3 years ago

browser_treeupdate_cssoverflow.js,browser_treeupdate_list.js,browser_treeupdate_list_editabledoc.js,browser_treeupdate_optgroup.js,browser_treeupdate_removal.js,browser_treeupdate_table.js,browser_treeupdate_textleaf.js | Test timed out | Found a tab

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox-esr45 --- unaffected
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mrbkap)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://treeherder.mozilla.org/logviewer.html#?job_id=37044233&repo=mozilla-inbound
Summary: Intermittent accessible/tests/browser/e10s/browser_treeupdate_optgroup.js | Test timed out - | Found a tab after previous test timed out: about:blank - → Intermittent accessible/tests/browser/e10s/browser_treeupdate_optgroup.js, browser_treeupdate_textleaf.js | Test timed out - | Found a tab after previous test timed out: about:blank -
On Aurora, retriggers confirm that this started on https://treeherder.mozilla.org/#/jobs?repo=mozilla-aurora&revision=43c3d294f63cd8e49fca491a686f729cfd66a365. Looking at the commits in that push, bug 1286911 stands out as the most likely culprit.
Blocks: 1286911
Flags: needinfo?(hsivonen)
Summary: Intermittent accessible/tests/browser/e10s/browser_treeupdate_optgroup.js, browser_treeupdate_textleaf.js | Test timed out - | Found a tab after previous test timed out: about:blank - → Intermittent browser_treeupdate_list_editabledoc.js,browser_treeupdate_optgroup.js,browser_treeupdate_removal.js,browser_treeupdate_textleaf.js | Test timed out | Found a tab after previous test timed out: about:blank -
Duplicate of this bug: 1307811
Summary: Intermittent browser_treeupdate_list_editabledoc.js,browser_treeupdate_optgroup.js,browser_treeupdate_removal.js,browser_treeupdate_textleaf.js | Test timed out | Found a tab after previous test timed out: about:blank - → Intermittent browser_treeupdate_list_editabledoc.js,browser_treeupdate_optgroup.js,browser_treeupdate_removal.js,browser_treeupdate_table.js,browser_treeupdate_textleaf.js | Test timed out | Found a tab after previous test timed out: about:blank -
Duplicate of this bug: 1306554
Summary: Intermittent browser_treeupdate_list_editabledoc.js,browser_treeupdate_optgroup.js,browser_treeupdate_removal.js,browser_treeupdate_table.js,browser_treeupdate_textleaf.js | Test timed out | Found a tab after previous test timed out: about:blank - → browser_treeupdate_cssoverflow.js,browser_treeupdate_list.js,browser_treeupdate_list_editabledoc.js,browser_treeupdate_optgroup.js,browser_treeupdate_removal.js,browser_treeupdate_table.js,browser_treeupdate_textleaf.js | Test timed out | Found a tab
Duplicate of this bug: 1307669
Duplicate of this bug: 1307807
This and bug 1307845 are quickly turning into dumping grounds. Let's hope we can find the cause of these sooner rather than later.
(In reply to Ryan VanderMeulen [:RyanVM] from comment #2)
> On Aurora, retriggers confirm that this started on
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> aurora&revision=43c3d294f63cd8e49fca491a686f729cfd66a365. Looking at the
> commits in that push, bug 1286911 stands out as the most likely culprit.

If bug 1286911 was to blame, we should see a content process crash stack pointing to https://dxr.mozilla.org/mozilla-central/source/parser/html/nsHtml5Tokenizer.h#161 , https://dxr.mozilla.org/mozilla-central/source/parser/html/nsHtml5Tokenizer.h#188 , https://dxr.mozilla.org/mozilla-central/source/parser/html/nsHtml5Tokenizer.cpp#251 or https://dxr.mozilla.org/mozilla-central/source/parser/html/nsHtml5TreeBuilderCppSupplement.h#958 .

I don't see these in the logs, which suggest bug 1286911 isn't the cause.
Flags: needinfo?(hsivonen)
Indeed, a Try push of bug 1286911 from Aurora still hits these failures. Thanks for the reply.
No longer blocks: 1286911
Targetted retriggers on Try confirm that this is fallout from the first patch from bug 1304531.
Blocks: 1304531
Flags: needinfo?(mrbkap)
Well, that's terrifying.
To be clear, we're talking about this specific changeset right?
https://hg.mozilla.org/releases/mozilla-beta/rev/c1072535a273
(In reply to David Bolter [:davidb] from comment #13)
> To be clear, we're talking about this specific changeset right?
> https://hg.mozilla.org/releases/mozilla-beta/rev/c1072535a273

(Err well I didn't mean beta specifically)
I haven't been able to reproduce this locally, but here's what I've found so far:

- The message being sent and failing is PDocAccessible::Name (from the parent to the child).
- This appears to be the result of the Logger.log statement at [1].
- PDocAccessible::Name is an urgent message but __delete__ is not.

That being said. I haven't been able to figure out how it's possible for us to end up with a race between getting the name and deleting the actor because, as I understand things, the events that cause us to log something should originate from the child and the *child* initiates actor destruction (via PDocAccessible::Shutdown) so once the child sends that, it shouldn't be sending updates for those actors anymore.

The easiest path forward here would probably be to avoid logging anything if logging is off. That way someone who understands the a11y IPC stuff better than me can investigate without the pressure of an intermittently-orange tree.

[1] http://searchfox.org/mozilla-central/rev/d96317a351af8aa78ab9847e7feed964bbaac7d7/accessible/tests/browser/e10s/events.js#71
Flags: needinfo?(mrbkap)
Any thoughts, Trev?
Flags: needinfo?(tbsaunde+mozbugs)
Assignee: nobody → mrbkap
Attachment #8802769 - Flags: review?(tbsaunde+mozbugs)
Comment on attachment 8802769 [details]
Bug 1307645 - Avoid this logging call when running mochitests to fix an intermittent orange.

This is wrong. I'll have a new patch tomorrow that actually runs at least some of the time.
Attachment #8802769 - Attachment is obsolete: true
Comment on attachment 8802769 [details]
Bug 1307645 - Avoid this logging call when running mochitests to fix an intermittent orange.

ugh, we really need to figure out what this crash is about, but fixing the random orange is useful.

I'm not sure the comment is really useful, and this seems reasonable enough on its own to save work in the case its pointless.
Flags: needinfo?(tbsaunde+mozbugs)
Attachment #8802769 - Flags: review?(tbsaunde+mozbugs) → review+
Comment on attachment 8802769 [details]
Bug 1307645 - Avoid this logging call when running mochitests to fix an intermittent orange.

Carrying forward r+ from the last patch. Trevor can't use mozreview :-/.
Attachment #8802769 - Flags: review?(tbsaunde+mozbugs) → review+
Since trevor can't stamp the patch in mozreview, I can't land through autoland (and the tree is closed), requesting checkin-needed.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3ed4c1405691
Avoid this logging call when running mochitests to fix an intermittent orange. r=tbsaunde
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/3ed4c1405691
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
I apparently forgot to mark the bug when uplifting this to Beta a couple weeks ago.
https://hg.mozilla.org/releases/mozilla-beta/rev/ed7eae7b2677
You need to log in before you can comment on or make changes to this bug.