Closed Bug 1307679 Opened 3 years ago Closed Last year

::before and ::after are not rendered correctly on <details>

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1472897

People

(Reporter: TYLin, Unassigned)

References

(Blocks 1 open bug)

Details

Filed per bug 1304441 comment 25.

Currently, we render summary element as the first child, but we put it before the ::before pseudo-element. And we hide ::before and ::after on a non-open details.  Blink and Webkit do different on the following examples.

[1] https://hg.mozilla.org/mozilla-central/raw-file/42c95d88aaaa7c2eca1d278399421d437441ac4d/layout/reftests/details-summary/details-before.html
[2] https://hg.mozilla.org/mozilla-central/raw-file/42c95d88aaaa7c2eca1d278399421d437441ac4d/layout/reftests/details-summary/details-after.html
Priority: -- → P3
Close this because bug 1472897 is fixing what this wanted to resolve.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1472897
You need to log in before you can comment on or make changes to this bug.