Status

RESOLVED DUPLICATE of bug 1314361
2 years ago
2 months ago

People

(Reporter: apps, Unassigned)

Tracking

48 Branch
Unspecified
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36

Steps to reproduce:

Try to open an IndexedDB with this standard code fails.

window.indexedDB = window.indexedDB || window.webkitIndexedDB || window.mozIndexedDB || window.msIndexedDB;

var request = window.indexedDB.open("MyDatabase");
request.onerror = function(event) {
  console.log("failure");
};
request.onsuccess = function(event) {
  console.log("success");
};

You can execute this code here https://jasonsavard.com/test.php
Note that I also see similar IndexedDB console errors when I start Firefox like below...

Quota 'moz-extension' is not a valid schema!: ActorsParent.cpp:6678 (unknown)
Quota Origin 'moz-extension+++527b42dc-5470-429e-b671-21e36c20085e' failed to parse, handled tokens: : ActorsParent.cpp:6598 (unknown)
IndexedDB UnknownErr: ActorsParent.cpp:584 (unknown)
UnknownError IndexedDBHelper.jsm:71:12


Actual results:

The onerror event is triggered with the following error message:

The operation failed for reasons unrelated to the database itself and not covered by any other error code.


Expected results:

The onsuccess event should be triggered.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10

Comment 1

2 years ago
Maybe similar to bug 1306596. Could you try to reinstall Firefox (without deleting your profile).
Flags: needinfo?(apps)
(Reporter)

Comment 2

2 years ago
Reinstalling Firefox did not work. (I uninstalled and installed)
I removed my Firefox profile and installed Firefox and now it does work.
Thanks for the tip I hope my feedback helps determine the issue.
Flags: needinfo?(apps)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → WebExtensions: General
Product: Firefox → Toolkit
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

2 years ago
For more information to the possible cause - I am a developer and have been loading and unloading a temporary WebExtension that uses an IndexedDB (which also had the same issue), but even after removing it the IndexedDB issue persisted at the browser level and the WebExtension level.

Updated

2 years ago
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1314361

Updated

2 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.