mozilla won't load any plugins- at least, RealPlayer and Flash

VERIFIED DUPLICATE of bug 124006

Status

()

Core
Plug-ins
P2
critical
VERIFIED DUPLICATE of bug 124006
16 years ago
16 years ago

People

(Reporter: Felipe, Assigned: av (gone))

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae: 20020311 : linux only crash], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/0
BuildID:    0000000000

plugins won't load w/ my fresh build of 0.9.9. Using gcc 3.0.4 and glibc 2.2.5,
and I get these error messages upon starting mozilla:

-----------
LoadPlugin: failed to initialize shared library
/home/fgasper/source/mozilla-0.9.9/dist/bin/plugins/libjavaplugin_oji140.so
[/home/fgasper/source/mozilla-0.9.9/dist/bin/plugins/libjavaplugin_oji140.so:
undefined symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]
LoadPlugin: failed to initialize shared library
/home/fgasper/source/mozilla-0.9.9/dist/bin/plugins/rpnp.so
[/home/fgasper/source/mozilla-0.9.9/dist/bin/plugins/rpnp.so: undefined symbol:
__pure_virtual]
------------------



Reproducible: Always
Steps to Reproduce:
1. compile mozilla w/ gcc 3.0.4 and glibc 2.95.3 using these config options:

./configure  --enable-strip --enable-optimize --disable-dtd-debug
--with-pthreads --disable-debug --enable-extensions --enable-xinerama
--enable-java-supplement --enable-crypto --enable-xft
--enable-default-toolkit=gtk --with-system-mng --with-system-png
--with-system-zlib --with-system-jpeg

2. Place RealPlayer and Flash plugins into mozilla/dist/bin/plugins
3. run mozilla/dist/bin/mozilla

Actual Results:  mozilla ran, initialized first-time run stuff, and gave above
error mesages. Loading a flash page (www.music.duq.edu) crashes the browser.

Expected Results:  loaded the plugins like normal; Flash has never worked
correctly w/ Mozilla, but at least it should try. :-)

possible bug in gcc?

Comment 1

16 years ago
testing this on win32 and it works correctly, I suspect this is a Linux only
issue.  Going to reassign this to Serge.

I did not confirm the crash. Serge if you can repro this on Linux, then please
put it in the appropriate milestone - thanks
Keywords: crash
Priority: -- → P2
Whiteboard: [bae: 20020311 : linux only crash]

Comment 2

16 years ago
this is gcc 3.x compiler problem, for workaround see bug 124006
I'm resolving this as a dup of bug 124006

*** This bug has been marked as a duplicate of 124006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.