Closed Bug 1307937 Opened 3 years ago Closed 2 years ago

Add animation for collapse button (console.group/trace, errors, …)

Categories

(DevTools :: Console, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1381819

People

(Reporter: linclark, Unassigned)

References

(Blocks 1 open bug)

Details

Originally posted by:nchevobbe

see https://github.com/devtools-html/gecko-dev/issues/326

Since there is one in the debugger (for example when toggling a folder in the source panel), it should behave the same in the console ( stacktrace, group, ... )
Priority: -- → P2
Whiteboard: new-console
Flags: qe-verify+
Priority: P2 → P3
QA Contact: iulia.cristescu
Whiteboard: new-console → [reserve-new-console]
Whiteboard: [reserve-new-console] → [reserve-console-html]
Summary: Add animation for collapse button → Add animation for collapse button (console.group/trace, errors, …)
Gabe, are you aware of an already implemented twisty arrow animation that we can use in the console? Would be great to unify across tools, so if there isn't one we can share it in common.css and hopefully reuse in things like the accordion component.
Flags: needinfo?(gl)
This is something I will eventually get to in the photon visual works. It is implemented in the Accordion for the debugger.html but they use inline svg which still causes some inconsistency with the rest of the twisty arrows in m-c.
(In reply to Gabriel [:gl] (ΦωΦ) from comment #2)
> This is something I will eventually get to in the photon visual works. It is
> implemented in the Accordion for the debugger.html but they use inline svg
> which still causes some inconsistency with the rest of the twisty arrows in
> m-c.

OK, sounds good! If we come up with a common style to use for everything except for debugger we can port that over to debugger once we get the stylesheets synced back into devtools-core. Going to block devtools-visual for now.
Flags: needinfo?(gl)
Priority: P3 → P4
Flags: qe-verify+
Priority: P4 → P2
QA Contact: iulia.cristescu
Whiteboard: [reserve-console-html] → [newconsole-mvp]
Priority: P2 → P3
Whiteboard: [newconsole-mvp] → [newconsole-reserve]
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1381819
Priority: P3 → --
Whiteboard: [newconsole-reserve]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.