Proxied IMAP doesn't work if proxy is autoconfigured

VERIFIED DUPLICATE of bug 78176

Status

VERIFIED DUPLICATE of bug 78176
17 years ago
10 years ago

People

(Reporter: h3i6m4z02, Assigned: mscott)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031005

Reading mail with IMAP via a SOCKS proxy doesn't work if the proxy
is autoconfigured, but does if manually configured. HTTP works
correctly with either the autoconfigured or manual proxy.


Reproducible: Always
Steps to Reproduce:
1. Select "autoconfigure" in the proxy preferences
2. Autoconfigure the proxy by pressing button or restarting Mozilla
3. Start mailnews for IMAP account.
4. Observe mailnews fail to connect to IMAP server.
5. Exit mailnews.
6. Select manual proxy configuration in proxy preferences.
7. Restart mailnews. Observe it to now work.


Actual Results:  mailnews hangs.


Expected Results:  mailnews should connect to IMAP server via the autoconfigured
proxy.
CC bbaetz
Can you attach your PAC file?

What socks version is your sever - PAC only does socks4, and theres a separate
bug on that.
(Reporter)

Comment 3

17 years ago
My manual proxy configuration uses socks5,
so that could be the "problem".

Here's the PAC file:

// Your address is 163.154.6.201 and i can't find you in my database! THIS IS A
BUG!!! Please report it to florin@sgi.com
// Default PAC file (catch-all)

function FindProxyForURL(url, host) {
	addr = dnsResolve(host)
	if (addr) {
		if (	0
			|| isInNet(addr, "127.0.0.1", "255.255.255.255"))
			return "DIRECT";
		else
			return "PROXY www-proxy.sgi.com:8080";
	} else
		return "PROXY www-proxy.sgi.com:8080";
}
There are two problems here:

First, PROXY is http - you need SOCKS to use sock.

Second, there isn't (yet) a way to do socks5 from a pac file.

Dupe of the bug for the second issue, I guess.

*** This bug has been marked as a duplicate of 78176 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: huang → stephend
verified dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.