If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Inspect Closes When Browsing to Site from New Tab Page

RESOLVED DUPLICATE of bug 1068400

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 1068400
a year ago
a year ago

People

(Reporter: u564464, Unassigned)

Tracking

49 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160916101415

Steps to reproduce:

Open new tab (about:newtab or about:blank).
Right click, open Inspect Element.
Type a website into the address bar.


Actual results:

The Inspect bar closes.


Expected results:

Inspector should stay open, loading console and network info from the visited website. It stays open correctly when browsing for the Private Window page about:privatebrowsing
(Reporter)

Updated

a year ago
Component: Untriaged → New Tab Page
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64
(Reporter)

Updated

a year ago
Summary: Inspect Closes When Browsing to Site from about:newtab → Inspect Closes When Browsing to Site from New Tab Page

Comment 1

a year ago
I can't reproduce it with FF49 on Win 7.

Is it reproducible with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(spammonster2011)

Updated

a year ago
Component: New Tab Page → Developer Tools: Inspector
(Reporter)

Comment 2

a year ago
(In reply to Loic from comment #1)
> I can't reproduce it with FF49 on Win 7.
> 
> Is it reproducible with a clean profile?
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles

On Mac OS X, yes, I reproduced it with a clean profile. Can't reproduce on Linux or Windows.
Flags: needinfo?(spammonster2011)

Comment 3

a year ago
Maybe it's a bug specific to the OSX version. Are you able to reproduce the issue in previous versions of Firefox?
AFAIK, the new tab page is loaded in the parent process with e10s, while web content is loaded in the content process.  At the moment we're not able to keep the toolbox open when switching processes like that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068400
You need to log in before you can comment on or make changes to this bug.