Closed Bug 1307997 Opened 5 years ago Closed 5 years ago

Widevine does not install on 64bit Windows

Categories

(Toolkit :: General, defect, P1)

x86_64
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1306516
Tracking Status
firefox49 --- unaffected
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 - fixed

People

(Reporter: shu, Assigned: daleharvey)

References

Details

(Keywords: 64bit, regression)

Cannot stream DRM videos on 64bit nightly right now. I'd say it's pretty important if we're pushing more 64bit builds onto users.

STR:

- Install 64bit Nightly 52
- Try to watch a movie on Amazon.
- See the little bar on the top pop up about installing stuff.
- Go to about:addons > Plugins
- See that Wildvine says "will be installed soon" but never does
cpeterson has confirmed he gets the bug too over IRC.
[Tracking Requested - why for this release]:

64-bit Nightly is unable to play Netflix.

I can reproduce this problem in Nightly 52, but not Release 49.
Flags: needinfo?(cpearce)
OS: Unspecified → Windows
Hardware: Unspecified → x86_64
Summary: Wildvine does not install on 64bit Windows → Widevine does not install on 64bit Windows
Dale: Is this a regression from your recent work? In the browser console I see

1475703702499	Toolkit.GMP	ERROR	GMPWrapper(gmp-widevinecdm) findUpdates() - updateTask for gmp-widevinecdm threw: TypeError: gmpAddons.find is not a function (resource://gre/modules/addons/GMPProvider.jsm:295:22) JS Stack trace: GMPWrapper.prototype.findUpdates/this._updateTask<@GMPProvider.jsm:295:22
[...]
1475703708509	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Addon |gmp-widevinecdm| not supported on this platform.
Flags: needinfo?(cpearce) → needinfo?(dale)
Priority: -- → P1
I ran a mozregression, and found that Bug 1267495 caused this regression. The "gmpAddons.find is not a function" error always co-occured with the failure during the regression run, so I expect that's related.

Dale, can you take this bug?
Blocks: 1267495
Component: Audio/Video: Playback → General
Product: Core → Toolkit
Version: unspecified → Trunk
Yeh this is likely a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=1306516 but will check and make sure before closing - https://bugzilla.mozilla.org/show_bug.cgi?id=1306516
Assignee: nobody → dale
Flags: needinfo?(dale)
Yup this is a dupe
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1306516
Tracking - as we can track this in the dupe if necessary.
fixed in 52 per the duplicate bug
You need to log in before you can comment on or make changes to this bug.