Background-Color style on an option element seems to have quit working with the new firefox update

RESOLVED DUPLICATE of bug 910022

Status

()

RESOLVED DUPLICATE of bug 910022
2 years ago
2 years ago

People

(Reporter: cbrown, Unassigned)

Tracking

49 Branch
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8798570 [details]
dropdown color chrome.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

I have a select element that changes the color of a row based on the selected option. These options are just blank options that contain a style="background-color:(Some Hex code);" Below is my code:

<select name="bom_bg_color_195898" id="bom_bg_color_195898" onchange="set_bom_bg(this,'195898');" class="unlocked">
  <option selected="" value="FFFFFF" style="background-color:#FFFFFF;"></option>
  <option value="FF3333" style="background-color:#FF3333;"></option>
  <option value="99CCFF" style="background-color:#99CCFF;"></option>
  <option value="CC99FF" style="background-color:#CC99FF;"></option>
  <option value="FF99CC" style="background-color:#FF99CC;"></option>
  <option value="FFCC99" style="background-color:#FFCC99;"></option>
  <option value="FFFF99" style="background-color:#FFFF99;"></option>
  <option value="99FF99" style="background-color:#99FF99;"></option>
</select>


Actual results:

This has always worked in the past but after the firefox update, the options show as white instead of the background-color. It still works in all other browsers, and when I "refresh" firefox it works the first time around and then fails afterwards.


Expected results:

Each option should have a colored background related to its Hex code. I have attached an image of what is expected and what outputs on all other browsers as well as an older version of firefox
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → All
Firefox: 49.0.1, Build ID: 20160922113459
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

I have manged to reproduce this issue on the latest Firefox (49.0.1) release and latest Nightly (52.0a1) build with e10s enabled. The dropdown list has a white background for each option.

If the e10s is disabled, the issue is no longer reproducible. Each option from the dropdown list has a specific background color.
Status: UNCONFIRMED → NEW
Component: General → Layout: Form Controls
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 910022
You need to log in before you can comment on or make changes to this bug.