Closed Bug 1308504 Opened 3 years ago Closed 3 years ago

Move drawWaterfallBackground to its own module

Categories

(DevTools :: Netmonitor, defect)

defect
Not set

Tracking

(firefox52 affected)

RESOLVED DUPLICATE of bug 1309866
Tracking Status
firefox52 --- affected

People

(Reporter: rickychien, Unassigned)

References

(Blocks 1 open bug)

Details

This function draws the waterfall view background (timing ticks) into a canvas element and sets the element as CSS background-image. Move this to a module and convert the complicated browser_net_timeline_ticks.js test to a simple unit test.

- Using canvas as CSS background is only supported by Firefox. Since we want to support loading Net panel in other browsers too, this should be changed.
- We might want to use % as units (get some inspiration from how Firebug and HARViewer are done)
Other places we can get inspiration from: Animation Inspector, Performance View
- This is adept for bigger rewrite.
- Don’t forget to remove canvas  from the onLoaded and onContentLoaded Events.
Whiteboard: [devtools-html]
Depends on: 1308694
Depends on: 1308695
Blocks: 1308695
No longer depends on: 1308695
Blocks: 1308694
No longer depends on: 1308694
Whiteboard: [netmonitor]
Flags: qe-verify+
QA Contact: ciprian.georgiu
Priority: -- → P2
No longer blocks: netmonitor-html
Priority: P2 → --
Whiteboard: [netmonitor]
drawWaterfallBackground is moved into its own module as part of bug 1309866

Honza
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309866
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.