Closed Bug 1308679 Opened 3 years ago Closed 3 years ago

Intermittent browser/components/originattributes/test/browser/browser_httpauth.js | This test exceeded the timeout threshold. It should be rewritten or split up. If that's not possible, use requestLongerTimeout(N), but only as a last resort. -

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 52
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jhao)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

This test got implemented in bug 1301523 and fails 6-12 times a day. jhao, can you take a look at this, please?
Blocks: 1301523
Flags: needinfo?(jhao)
I'm seeing this trigger a lot in a try build.  I think bug 1301340 made this worse on Oct 12 by changing the timing of the cleanup code.  Due to the second set of prefs being set flushPrefEnv() is now taking longer and seems to hang.  If I revert back to a single set of prefs the frequency of the problem is reduced.

Its unclear to me what this is racing against, though.  It seems the test should be waiting for something before proceeding.
Well, I'm less sure now if that is the problem.  But the failures did increase around Oct 12 when bug 1301340 landed.  Its worth checking to see if it increased the frequency.
Assignee: nobody → jhao
Flags: needinfo?(jhao)
Ben, can you find an assignee who works on this? jhao is on pto and this bug should be fixed before the merge (Nov 7th), there wouldn't be much time left for this after jhao's return (Nov 3rd). Thank you.
Flags: needinfo?(bkelly)
I'm sorry, but I don't really know who would be a good person to work this.  In theory someone who has worked on the first party isolation or someone in the firefox org familiar with browser chrome testing.
Flags: needinfo?(bkelly)
Arthur, please take a look at comment 11.
Flags: needinfo?(arthuredelstein)
:ethan, can you help find somebody else on :jhao's team to look at this bug?
Flags: needinfo?(ettseng)
Nearly all of these failures are on Linux Debug, with most of those on e10s. If you look at successful runs of this test on Linux Debug, e10s, they generally take between 40 and 45 seconds to complete. That holds true even on runs when the test was first implemented. Consider this log from 2016-10-08:

https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-linux-debug/1475895442/mozilla-central_ubuntu32_vm-debug_test-mochitest-e10s-browser-chrome-1-bm07-tests1-linux32-build2.txt.gz

252 INFO TEST-OK | browser/components/originattributes/test/browser/browser_httpauth.js | took 45322ms

mochitest-bc tests will time out if they take >45 seconds, so I think these failures are just a product of a long-running test running just a bit longer.

I don't see an obvious way to split it up, so perhaps requestLongerTimeout() is the best way forward?
yeah, I don't see anything wrong with requestLongerTimeout()- it isn't good as it can lead to longer running tests, but in this case it gets us past a recurring issue until we can revisit the test.
(In reply to Joel Maher ( :jmaher) from comment #17)
> :ethan, can you help find somebody else on :jhao's team to look at this bug?

Tim, please help to look into this bug.
Flags: needinfo?(ettseng) → needinfo?(tihuang)
I think the requestLongerTimeout() would be a better way to resolve this problem since the test framework here will run the same test three times with different settings. So, the test here represents three tests. Maybe we could find a way that to split one test into three test files, but I think this is not a good solution here because it is hard to maintain, and would be annoying when adding new test cases. 

Baku, do you have any suggestion for this? Or we could use requestLongerTimeout() to address this issue.
Flags: needinfo?(tihuang) → needinfo?(amarchesini)
Comment on attachment 8805836 [details]
Bug 1308679 - Request a longer timeout for the tests that use first party isolation test framework.

https://reviewboard.mozilla.org/r/89466/#review88732
Attachment #8805836 - Flags: review?(amarchesini) → review+
Try looks good.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/6abc545be46e
Request a longer timeout for the tests that use first party isolation test framework. r=baku
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6abc545be46e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Flags: needinfo?(arthuredelstein)
Flags: needinfo?(amarchesini)
(In reply to OrangeFactor Robot from comment #34)
> For more details, see:
> https://brasstacks.mozilla.com/orangefactor/
> ?display=Bug&bugid=1308679&startday=2016-10-31&endday=2016-11-06&tree=all

It seems the intermittent was really resolved.  :)
Duplicate of this bug: 1308678
You need to log in before you can comment on or make changes to this bug.