Closed Bug 1308690 Opened 5 years ago Closed 5 years ago

Use Reselect module for memoized selectors for sorting functions

Categories

(DevTools :: Netmonitor, defect)

defect
Not set
normal

Tracking

(firefox52 affected)

RESOLVED DUPLICATE of bug 1309866
Tracking Status
firefox52 --- affected

People

(Reporter: rickychien, Unassigned)

References

Details

We might run into performance issues in the future since the calculation for sorting large amounts of network requests every time is expensive. In order to compute derived data efficiently from the Redux store, we should introduce reselect to memoized selectors.

This bug is a follow-up for bug 1308480.

- Introduce reselect for sort-predicates.js
Blocks: netmonitor-html
No longer blocks: 1308480
Depends on: 1308480
Whiteboard: [netmonitor]
Flags: qe-verify+
QA Contact: ciprian.georgiu
Priority: -- → P2
No longer blocks: netmonitor-html
Priority: P2 → --
Whiteboard: [netmonitor]
This is being implemented as part of bug 1309866

Honza
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309866
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.