Closed Bug 1308719 Opened 3 years ago Closed 3 years ago

Firefox should pass unrecognized commandline options (like --class ) to new FF instance when restarting itself

Categories

(Toolkit :: Startup and Profile System, defect, P5)

51 Branch
Unspecified
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 849571

People

(Reporter: c4609174, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161007004004

Steps to reproduce:

Some background info: I have several Firefox instances installed on Debian x64 with GNOME here. So when starting GNOME confused these Firefox instances and sometimes showed the wrong name in the title.
More details can be found here: https://unix.stackexchange.com/questions/314338/gnome-confuses-names-of-multiple-different-firefox-installations/314833

So from the linked Stackoverflow question you see I found a solution: I have to use the --class parameter. When the --class parameter matches the StartupWMClass in my desktop file, everything is right and GNOME recognizes all Firefox instances correctly.

However, when Firefox restarts itself it does not seem to pass the old --class parameter to the new instance, so that this new instance is again confused by GNOME.

So some - very basic - STR:

Preparation:
1. Install multiple Firefoxes. (recommend: Dev Edition and stable)
2. Make sure GNOME confuses them when started.
3. Now start them with the correct --class parameter and make sure GNOME does *not* confuse them.

Reproduce:
1. Now use the correctly (with --class) started Firefox and e.g. install an add-on, which requires restarts or install a Firefox update.
2. Restart from inside Firefox (click the link).


Actual results:

GNOME confuses the new instance of Firefox as Firefox is restarted without the --class parameter.


Expected results:

GNOME should not confuse the new instance of Firefox, so Firefox should be restarted with the --class parameter, which was passed to it initially.
Has STR: --- → yes
Component: Untriaged → General
OS: Unspecified → Linux
BTW all in all you might want to fix it, so that Firefox just keeps the same parameters everytime when it restarts itself.
Component: General → Untriaged
Product: Firefox → Core
Summary: Firefox should pass --class to new FF instance when restarting itself → Firefox should pass unrecognized commandline options (like --class ) to new FF instance when restarting itself
Hi rugk, I didn't manage to set up the environment and test the issue but I will assign a possible related component. Maybe someone with more experience regarding the browser configuration could provide some feedback for this issue.
Component: Untriaged → Startup and Profile System
Product: Core → Toolkit
Basically I would say you do not need to setup the complete same environment. It may be enough to use Linux and to start firefox with the --class parameter. Then trigger a restart from Firefox and see if the new instance also has the --class parameter in its command line. If not, then you got this bug.
Priority: -- → P5
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 849571
You need to log in before you can comment on or make changes to this bug.