0.9.9 won't start after install

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
critical
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Allen Castaban, Assigned: Peter Trudelle)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    20020301

After installing 0.9.9/upgrading from 0.9.8, Mozilla hangs. I had to re-install 0.9.8. Installed both to the same directory as 0.9.8 or a fresh one. Same result. I am using W2K SP2

Reproducible: Always
Steps to Reproduce:
1.As above
2.
3.
(Reporter)

Comment 1

16 years ago
Sorry, I forgot to mention. I used the full installer (not the zip file)
Reporter: 
Can you try a new profile ?
(run "mozilla -profilemanager")
(Reporter)

Comment 3

16 years ago
I tried a new profile. No difference. Still hangs when I try with the new profile. Is there any other files I might delete maybe, I know there was a *.hst *.db file in 4.7 which used to cause problems

Updated

16 years ago
URL: N/A
Severity: critical → blocker
Keywords: hang
(Assignee)

Comment 4

16 years ago
What mozilla development work is this blocking?
trudelle: 
ask oliver.klee@gmx.net
"Blocker Blocks development and/or testing work" I bet he means "testing work"

Reporter: 
Do you try to migrate an 4.7x profile or a brand new Mozilla profile ?
Do you run the installer as user or as Admin ?
(Assignee)

Comment 6

16 years ago
Yeah, I know what blocker severity is (I got it added).  What work does this
block?  
(Reporter)

Comment 7

16 years ago
I migrated my 4.7 profile a long while ago, many many releases ago. Since then I had my profile freshly created. Originally I installed after using 0.9.8, using the same profile. Then I tried to create a new profile for testing purposes. See the comment above. Did not make any difference.

I installed it as Admin

Comment 8

16 years ago
I had changed the severity to Blocker because this bugs blocks any Mozilla
testing for the reporter. Please correct if I've misunderstood the severity
descriptions at http://bugzilla.mozilla.org/bug_status.html#severity . Thanks
(Assignee)

Comment 9

16 years ago
->critical, since there is no apparent testing *work* blocked by this defect.
Could you please try installing without admin privileges?
Severity: blocker → critical
(Reporter)

Comment 10

16 years ago
How can I install S/W in W2K without admin priviledges? Plus I always work with a userid with admin priv. I did not have problems with 0.9.8.
This is supposed to be backwards. You might have problems without admin priviledges, not with admin priviledges
(Assignee)

Comment 11

16 years ago
I was just trying to cover all permutations.  I actually install every day using
a Win32 account with admin privileges.  Have you tried completely removing the
program, re-installing clean, and creating a new profile? It is likely there is
something awry on your machine, or we'd be hearing this a lot more. 

Comment 12

16 years ago
I've had the same problem on Win 98 SE.  I can't get any build after
mid-February to work.  I was using a build from about a week after 0.9.8.  I
upgraded to 0.9.9 and it hung after the default browser dialog box.  I've since
tried installing various nighlies back to the oldest one on the ftp server and
none of them work.  I went back to 0.9.8.  

I've tried upgrading and installing clean and using installers and zip files. 
The only thing I didn't try was wiping my profiles.
(Assignee)

Comment 13

16 years ago
Okay, then please try a completely new profile.  Also, what do you mean by
'clean install'?  I delete the old directory first, and if I run into any
problems I delete c:\windows\mozver.dat and even the registry.dat file in my
profile too.
(Reporter)

Comment 14

16 years ago
I am glad there is at least one more person who is having similar problems. Things I tried:
1) Install on top of 0.9.8  - Failed
2) Install to a new directory (Without deleting the old ones, I am reluctant to do that, I don't wanna left without a working browser) - Failed
3) Installed with a new profile - Failed
4) Renaming mozver.dat and registry.dat (Without a reinstall, useing a previous 0.9. install) - Failed
5) Install 0.9.9 to my home computer, who is running almost the same configuration. - Succesfull.  So this points to some sort of a setup problem, but what else can I try to figure out what is the problem.
Is thare any way to find out (like a hidden debugging option or so) to tell where this damn thing is hanging (like hanging doing what, this might point us to a direction...
I am OK with this, if 1.0.0 will work, but if it doesn't that is a major major problem for me...

Comment 15

16 years ago
By clean install I meant I deleted the directory and leftover registry keys.  I
also did try a new profile, but I didn't delete my old profile directory or
c:\windows\mozver.dat.  I will give that a try as well as soon as possible.
  

Comment 16

16 years ago
Is this bug stale ?

Comment 17

16 years ago
Since this bug was reported, a newer version of Mozilla (1.0 RC1) has been
released. Reporter (Allen Castaban), please can you check to see whether this
bug is still present in a recent build (Moz1-RC1 or a new nightly build). If
this bug does not occur please can you resolve it worksforme.

Please do not install a new copy of Mozilla directly over an existing one. This
will lead to known problems.
(Reporter)

Comment 18

16 years ago
As per email I sent to Peter Trudelle,  when I installed 1.0, it seemed to hang, after a long delay (like 5 mins or so), the application came back and now it seems to be working OK. I don't have a problem anymore

Comment 19

16 years ago
Marking worksforme from reporter's comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 20

16 years ago
Note that no matter what the directions say, most users will install directly
over an existing copy. Any problems caused by that will rightly be perceived as
defects.

Comment 21

16 years ago
Peter I have filed bug 140537 to discuss whether some safeguards can be put in
place to try and prevent users doing this.
(Reporter)

Comment 22

16 years ago
With all due respect, it is a big deficiency that the user has to install to a fresh directory. All the applications around they always install to the same directory.
And what will happen to the old directory? Can it be safely deleted? Does it need to uninstalled using Windows Uninstall?
When you install to a fresh directory, you generally loose your plugins and stuff. It is not very user friendly at all. Instead of trying to put effort to keep something deficient, efforts should be put to fix the problem, i.e. let the user install to the same directory.
I never had any problems installing to the same directory anyway
(Assignee)

Comment 23

16 years ago
Uh, we do allow installing over an existing copy, and default to it. Users
shouldn't have to care about any of these questions, we should handle every case
reasonably. Please report any defects you can trace to problems with this.

Comment 24

16 years ago
Peter, before I knew that you should clear out the old installation,
practically every other build was goosed was for me. Random problems
such as broken widgets, focus problems, rendering problems, etc. often
disappeared after a clean install.

Along with the occassional necessary nuking of component.reg this in my
experience was the cause of most of my problems with Mozilla on Linux
from CVS, and before that from nightly builds. Does the installer do 
something special here ?

It's obviously extremely difficult to track down problems that are caused by
this ...

Just look round bugzilla and you'll see hundreds of similar examples.
(Assignee)

Comment 25

16 years ago
Yes, I'm well aware of the problem, have filed some of those bugs, and routinely
delete my old folders every day before installing the latest verification
builds. I'm not sure what you expect me to do about it though, especially in
this bug that is resolved as wfm.  I don't know if mozilla.org can afford to
solve this problem, since they have more expert users and frequent releases, but
Netscape wants its users to be able to upgrade smoothly between released
versions, even beta releases, so we will be fixing serious defects that impair
upgrading.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.