Music/sound stop play on closing anonymous window

RESOLVED DUPLICATE of bug 1194891

Status

()

RESOLVED DUPLICATE of bug 1194891
2 years ago
2 years ago

People

(Reporter: svecpetr, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

When you are playing radio from internet i.e. http://vysilani.frekvence1.cz/hity
opened in normal panel

then when you open anonymous panel and any page




Actual results:

when you close anonymous panel

music from normal panel will stop playing


Expected results:

music shloud play ... is no reason to kill non anonymous process

Updated

2 years ago
Group: firefox-core-security
what do you mean with "normal panel", "anonymous panel", and "non anonymous process" ?
Flags: needinfo?(svecpetr)
(Reporter)

Comment 2

2 years ago
Created attachment 8800241 [details]
see enclosure ... this bug afects minimally windows and ubuntu

see enclosure ... this bug afects minimally windows and ubuntu
so, the steps to reproduce is following?
  1. open Firefox 49.0.1
  2. open http://vysilani.frekvence1.cz/hity
  3. wait for the music to start
  4. open New Private Window
  5. close the Private Window opened by step 4

I cannot confirm the issue on debian + Firefox 49.0.1 (64bit), with and without e10s

Does the issue happen with safe mode [1] and clean profile [2] ?
Also, if the music stops, does the speaker icon in the tab change?

[1] https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
[2] https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
(Reporter)

Comment 4

2 years ago
(In reply to Tooru Fujisawa [:arai] from comment #3)
> so, the steps to reproduce is following?
>   1. open Firefox 49.0.1
>   2. open http://vysilani.frekvence1.cz/hity
>   3. wait for the music to start
>   4. open New Private Window
>   5. close the Private Window opened by step 4
> 
> I cannot confirm the issue on debian + Firefox 49.0.1 (64bit), with and
> without e10s
> 
> Does the issue happen with safe mode [1] and clean profile [2] ?
> Also, if the music stops, does the speaker icon in the tab change?
> 
> [1]
> https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-
> mode
> [2]
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles

yes, this steps to reproduce

same bug on Windows or Ubuntu
can you also answer these questions?

> Does the issue happen with safe mode [1] and clean profile [2] ?
> Also, if the music stops, does the speaker icon in the tab change?
(Reporter)

Comment 6

2 years ago
icon of speaker is still showing, but no sound is playing

in safe-mode is it same, no sound after anonymous panel close

in new profile is it same, no sound after anonymous panel close

and behavior of firefox is same in Ubuntu 16.04 64bit or Window 10 Pro 64bit
Thanks.

Does the issue happen also on other website like this?
  https://www.youtube.com/watch?v=LtOGa5M8AuU
Created attachment 8800297 [details]
web audio sine wave example

also, how about this?

this page generates sound, without network transfer
(Reporter)

Comment 9

2 years ago
on mentioned youtube it work well, still playing sound/video
or http://listen.play.cz/player.html?shortcut=cernahora&format=wma,aac,mp3


but 
on http://vysilani.frekvence1.cz/hity
or http://blanik.static.abradio.cz/nove/player-cz-128.html

sound stops... icon is showed and network (download) is still active 
(sometimes radio begin play but that about 1 minute of silent)

so it would be in technology (plugin)
sounds like it's specific to live streaming.
maybe buffer runs out for some reason?

does the issue happen also when you're running some heavy job?
also, does the issue happen when you close normal window?
sorry, I missed the first URL ( http://listen.play.cz/player.html?shortcut=cernahora&format=wma,aac,mp3 )
it's also live streaming...

Updated

2 years ago
See Also: → bug 1309642
I suspect this is a duplicate of bug 1194891.

Comment 13

2 years ago
(In reply to Josh Matthews [:jdm] from comment #12)
> I suspect this is a duplicate of bug 1194891.

Totally.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(svecpetr)
Resolution: --- → DUPLICATE
Duplicate of bug: 1194891
You need to log in before you can comment on or make changes to this bug.