Status

()

defect
RESOLVED DUPLICATE of bug 1304539
3 years ago
3 years ago

People

(Reporter: glasolin, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Posted image 1.png
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160920074044

Steps to reproduce:

While using canvas and fillText() context function, the text shadow is not being rendered, though it was specified in code explicity.

for example:
===Cut===
var canvas = document.getElementsByTagName("canvas")[0],
    ctx = canvas.getContext('2d');

ctx.shadowColor = "black";
ctx.shadowOffsetX = 5; 
ctx.shadowOffsetY = 5; 
ctx.shadowBlur = 7;
ctx.font = "40px 'Helvetica'";
ctx.textBaseline = 'alphabetic';
ctx.scale(1,1);
ctx.fillStyle = "red";
ctx.fillText("Hallo Welt", 50, 100);
===Cut===

Live example is here:
https://jsfiddle.net/DirkWeber/nnqc8/1/




Actual results:

Text with no shadow rendered (1.png)


Expected results:

Text with shadow should be rendered
(Reporter)

Updated

3 years ago
OS: Unspecified → All
Hardware: Unspecified → All

Updated

3 years ago
Component: Untriaged → Canvas: 2D
Product: Firefox → Core

Comment 1

3 years ago
@reporter,
Could you test with Beta50.0b6[1], Dev51.0a2[2] and Nightly52.0a1[3]?

[1] https://www.mozilla.org/en-US/firefox/channel/#beta
[2] https://www.mozilla.org/en-US/firefox/channel/#developer
[3] https://nightly.mozilla.org/
Flags: needinfo?(glasolin)

Comment 2

3 years ago
Already fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(glasolin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1304353
(In reply to Loic from comment #2)
> Already fixed.
> 
> *** This bug has been marked as a duplicate of bug 1304353 ***

Actually, I think it's more likely a dupe of bug 1304539, though I haven't double-checked by testing against builds with each patch individually.
Duplicate of bug: 1304539
You need to log in before you can comment on or make changes to this bug.