Closed Bug 1309463 Opened 4 years ago Closed 4 years ago

Widevine not installing

Categories

(Core :: Audio/Video: Playback, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
platform-rel --- +
firefox51 + wontfix
firefox52 --- fixed

People

(Reporter: ajones, Assigned: daleharvey)

References

Details

(Whiteboard: [platform-rel-Netflix])

Attachments

(1 file, 2 obsolete files)

Steps to reproduce:

1. Navigate to about:preferences#content
2. Uncheck Play DRM Content
3. Check Play DRM Content
4. Navigate to about:addons
5. Click on Plugins
6. Navigate to netflix.com
7. Observe message saying Nightly is installing components...

Expected results:

Widevine installs after a few seconds

Actual results:

Widevine does not install

Note: Forcing install from about:addons works. Widevine installation from a fresh profile also doesn't work.
Flags: needinfo?(dale)
Argh sorry, taking a look now
Flags: needinfo?(dale)
Looking at the code I almost certainly made a mistake with the |isXPorVista64| definition @ https://dxr.mozilla.org/mozilla-central/source/toolkit/modules/GMPInstallManager.jsm#42, which looks like on 64bit Windows 7/8 (or anything above vista) the eme/widevine plugin will not be installed if you do not have a connection. (installations with an internet connection should not be affected at all)

Anthony is that the bug you see or do you have different circumstances (ie are you on windows and performing the installation with aus servers 'down')?
Flags: needinfo?(ajones)
I'm using 64 bit Firefox on Windows 10 on a clean profile. Here are is the log:


1476751271361	Toolkit.GMP	TRACE	GMPProvider.startup - enabled=true, gmpPath=C:\Users\Anthony Jones\AppData\Roaming\Mozilla\Firefox\Profiles\6b3gic0m.clean\gmp-gmpopenh264\1.6
1476751271362	Toolkit.GMP	INFO	GMPProvider.startup - adding gmp directory C:\Users\Anthony Jones\AppData\Roaming\Mozilla\Firefox\Profiles\6b3gic0m.clean\gmp-gmpopenh264\1.6
1476751271363	Toolkit.GMP	TRACE	GMPProvider.startup - enabled=false, gmpPath=null
1476751271363	Toolkit.GMP	TRACE	GMPProvider.startup - enabled=true, gmpPath=null
1476751271363	Toolkit.GMP	INFO	GMPProvider.startup - adding clearkey CDM directory C:\Program Files\Nightly\gmp-clearkey\0.1
The resource from “https://www.netflix.com/ichnaea/cl2/freeform/WebsiteDetect?source=wwwhead&fetchType=css” was blocked due to MIME type mismatch (X-Content-Type-Options: nosniff).  (unknown)
1476751280445	Toolkit.GMP	TRACE	GMPWrapper(gmp-eme-adobe) receiveMessage() data={"keySystem":"com.widevine.alpha","status":"cdm-not-installed"}
1476751280446	Toolkit.GMP	TRACE	GMPWrapper(gmp-widevinecdm) receiveMessage() data={"keySystem":"com.widevine.alpha","status":"cdm-not-installed"}
1476751280449	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Last check was: 1476751280 seconds ago, minimum seconds: 86400
1476751280449	Toolkit.GMP	INFO	GMPInstallManager._getURL Using url: https://aus5.mozilla.org/update/3/GMP/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml
1476751280452	Toolkit.GMP	INFO	GMPInstallManager._getURL Using url (with replacement): https://aus5.mozilla.org/update/3/GMP/52.0a1/20161017030209/WINNT_x86_64-msvc-x64/en-US/nightly/Windows_NT%2010.0.0.0%20(x64)/default/default/update.xml
1476751280453	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Last check was: 1476751280 seconds ago, minimum seconds: 86400
1476751280453	Toolkit.GMP	INFO	GMPInstallManager._getURL Using url: https://aus5.mozilla.org/update/3/GMP/%VERSION%/%BUILD_ID%/%BUILD_TARGET%/%LOCALE%/%CHANNEL%/%OS_VERSION%/%DISTRIBUTION%/%DISTRIBUTION_VERSION%/update.xml
1476751280454	Toolkit.GMP	INFO	GMPInstallManager._getURL Using url (with replacement): https://aus5.mozilla.org/update/3/GMP/52.0a1/20161017030209/WINNT_x86_64-msvc-x64/en-US/nightly/Windows_NT%2010.0.0.0%20(x64)/default/default/update.xml
MediaKeySystemAccess::GetKeySystemStatus(com.widevine.alpha, minVer=-1) result=cdm-not-installed version='' msg='CDM is not installed'
An unbalanced tree was written using document.write() causing data from the network to be reparsed. For more information https://developer.mozilla.org/en/Optimizing_Your_Pages_for_Speculative_Parsing  adtech_iframe_target_03.html:80
1476751281190	Toolkit.GMP	INFO	GMPAddon.constructor Created new addon: gmp-eme-adobe (isValid: true, isInstalled: false, hashFunction: sha512, hashValue: bd1e1a370c5f9dadc247c9f00dd203fab1a75ff3afed8439a0a0bfcc7e1767d0da68497140cbe48daa70e2535dde5f220dd7b344619cecd830a6b685efb9d5a0, size: 4853103)
1476751281191	Toolkit.GMP	INFO	GMPAddon.constructor Created new addon: gmp-gmpopenh264 (isValid: true, isInstalled: true, hashFunction: sha512, hashValue: 5030b47065e817db5c40bca9c62ac27292bbf636e24698f45dc67f03fa6420b97bd2f792c1cb39df65776c1e7597c70122ac7abf36fb2ad0603734e9e8ec4ef3, size: 404355)
1476751281191	Toolkit.GMP	INFO	GMPAddon.constructor Created new addon: gmp-widevinecdm (isValid: true, isInstalled: false, hashFunction: sha512, hashValue: 33497f3458846e11fa52413f6477bfe1a7f502da262c3a2ce9fe6d773a4a2d023c54228596eb162444b55c87fb126de01f60fa729d897ef5e6eec73b2dfbdc7a, size: 2853777)
1476751281192	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Found 3 addons advertised.
1476751281192	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Found addon: gmp-eme-adobe (isValid: true, isInstalled: false, hashFunction: sha512, hashValue: bd1e1a370c5f9dadc247c9f00dd203fab1a75ff3afed8439a0a0bfcc7e1767d0da68497140cbe48daa70e2535dde5f220dd7b344619cecd830a6b685efb9d5a0, size: 4853103)
1476751281192	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Addon |gmp-eme-adobe| not supported on this platform.
1476751281192	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Found addon: gmp-gmpopenh264 (isValid: true, isInstalled: true, hashFunction: sha512, hashValue: 5030b47065e817db5c40bca9c62ac27292bbf636e24698f45dc67f03fa6420b97bd2f792c1cb39df65776c1e7597c70122ac7abf36fb2ad0603734e9e8ec4ef3, size: 404355)
1476751281193	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Addon |gmp-gmpopenh264| already installed.
1476751281193	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Found addon: gmp-widevinecdm (isValid: true, isInstalled: false, hashFunction: sha512, hashValue: 33497f3458846e11fa52413f6477bfe1a7f502da262c3a2ce9fe6d773a4a2d023c54228596eb162444b55c87fb126de01f60fa729d897ef5e6eec73b2dfbdc7a, size: 2853777)
1476751281193	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Addon |gmp-widevinecdm| not supported on this platform.
1476751281193	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall No new addons to install, returning
1476751281224	Toolkit.GMP	INFO	GMPAddon.constructor Created new addon: gmp-eme-adobe (isValid: true, isInstalled: false, hashFunction: sha512, hashValue: bd1e1a370c5f9dadc247c9f00dd203fab1a75ff3afed8439a0a0bfcc7e1767d0da68497140cbe48daa70e2535dde5f220dd7b344619cecd830a6b685efb9d5a0, size: 4853103)
1476751281224	Toolkit.GMP	INFO	GMPAddon.constructor Created new addon: gmp-gmpopenh264 (isValid: true, isInstalled: true, hashFunction: sha512, hashValue: 5030b47065e817db5c40bca9c62ac27292bbf636e24698f45dc67f03fa6420b97bd2f792c1cb39df65776c1e7597c70122ac7abf36fb2ad0603734e9e8ec4ef3, size: 404355)
1476751281224	Toolkit.GMP	INFO	GMPAddon.constructor Created new addon: gmp-widevinecdm (isValid: true, isInstalled: false, hashFunction: sha512, hashValue: 33497f3458846e11fa52413f6477bfe1a7f502da262c3a2ce9fe6d773a4a2d023c54228596eb162444b55c87fb126de01f60fa729d897ef5e6eec73b2dfbdc7a, size: 2853777)
1476751281224	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Found 3 addons advertised.
1476751281224	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Found addon: gmp-eme-adobe (isValid: true, isInstalled: false, hashFunction: sha512, hashValue: bd1e1a370c5f9dadc247c9f00dd203fab1a75ff3afed8439a0a0bfcc7e1767d0da68497140cbe48daa70e2535dde5f220dd7b344619cecd830a6b685efb9d5a0, size: 4853103)
1476751281224	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Addon |gmp-eme-adobe| not supported on this platform.
1476751281224	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Found addon: gmp-gmpopenh264 (isValid: true, isInstalled: true, hashFunction: sha512, hashValue: 5030b47065e817db5c40bca9c62ac27292bbf636e24698f45dc67f03fa6420b97bd2f792c1cb39df65776c1e7597c70122ac7abf36fb2ad0603734e9e8ec4ef3, size: 404355)
1476751281224	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Addon |gmp-gmpopenh264| already installed.
1476751281225	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Found addon: gmp-widevinecdm (isValid: true, isInstalled: false, hashFunction: sha512, hashValue: 33497f3458846e11fa52413f6477bfe1a7f502da262c3a2ce9fe6d773a4a2d023c54228596eb162444b55c87fb126de01f60fa729d897ef5e6eec73b2dfbdc7a, size: 2853777)
1476751281225	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall Addon |gmp-widevinecdm| not supported on this platform.
1476751281225	Toolkit.GMP	INFO	GMPInstallManager.simpleCheckAndInstall No new addons to install, returning
Flags: needinfo?(ajones)
So this should fix it, will push to try and verify, thinking of how to test it right now
Comment on attachment 8802090 [details] [diff] [review]
Bug 1309463 - Fix check for supported EME platforms

Review of attachment 8802090 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/modules/GMPInstallManager.jsm
@@ +45,5 @@
>      return false;
>    }
>    let sysInfo = Cc["@mozilla.org/system-info;1"].getService(Ci.nsIPropertyBag2);
> +  let version = parseFloat(sysInfo.getProperty("version"));
> +  return (version < 6) || (version < 7 && Services.appinfo.is64Bit);

Windows 7 version is 6.1, not 7.
Thanks for that, so in looking for testing this, there is already similiar checks done on the plugin @ https://dxr.mozilla.org/mozilla-central/source/toolkit/modules/GMPUtils.jsm#44

Chris, Ben - It looks like these checks are a little more comprehensive and test similiar attributes, the only thing I see missing is it looks like 64bit Vista would be allowed by this check, do yall think its sufficient to add the 64bit Vista check to here and remove |if (gmpAddon.isEME && isXPOrVista64) {|?

Cheers
Flags: needinfo?(cpearce)
Flags: needinfo?(bhearsum)
I missed this check in my original patch, this is a lot better as it consolidates the existing logic and fixes it to not show widevine as available on 64bit Vista
Attachment #8802090 - Attachment is obsolete: true
Flags: needinfo?(bhearsum)
(In reply to Dale Harvey (:daleharvey) from comment #6)
> Chris, Ben - It looks like these checks are a little more comprehensive and
> test similiar attributes, the only thing I see missing is it looks like
> 64bit Vista would be allowed by this check, do yall think its sufficient to
> add the 64bit Vista check to here and remove |if (gmpAddon.isEME &&
> isXPOrVista64) {|?

I think that's ok, but I've not tested it.
Flags: needinfo?(cpearce)
Talked with Mike about this and it seems like manual testing is going to be best here, doing a try run (to make sure there are no failures) and to get builds to test on.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=1580ee97fe365bba018c5099331779b91bc71dd0
kentuckyfriedtakahe clarified that we have no restrictions to installing WideVine on 64bit Vista so there was no need for the extra check here
Attachment #8802125 - Attachment is obsolete: true
Firefox isn't supported on 64bit Vista:
https://www.mozilla.org/en-US/firefox/49.0.1/system-requirements/

I thought AUS wasn't serving a CDM to 64bit Vista either.
So we do not need to check 64bit Vista anyway :)
Comment on attachment 8802578 [details] [diff] [review]
Bug 1309463 - Fix check for supported EME platforms

Ok tested this and its all looking fixed, in the original patch I added some checks about what platforms we support, there was a bug in those checks and I missed that we already have code to perform those checks elsewhere, so we can just remove my added checks.
Attachment #8802578 - Flags: review?(mconley)
Attachment #8802578 - Flags: feedback?(ajones)
Comment on attachment 8802578 [details] [diff] [review]
Bug 1309463 - Fix check for supported EME platforms

Review of attachment 8802578 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, looks like the original patch was being overly aggressive, and we're doing the appropriate checks elsewhere (http://searchfox.org/mozilla-central/rev/703b663355467293fad148ab7c2c5ee2b878e4d9/toolkit/modules/GMPUtils.jsm#71 by way of http://searchfox.org/mozilla-central/rev/703b663355467293fad148ab7c2c5ee2b878e4d9/toolkit/modules/GMPInstallManager.jsm#234), so this change makes sense to me.

Thanks Dale!
Attachment #8802578 - Flags: review?(mconley) → review+
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4ec817d1c6ce
Fix check for supported EME platforms. r=mconley
https://hg.mozilla.org/mozilla-central/rev/4ec817d1c6ce
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Comment on attachment 8802578 [details] [diff] [review]
Bug 1309463 - Fix check for supported EME platforms

Review of attachment 8802578 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. The extra logic doesn't add any value because we just pref EME off altogether where it is not supported.
Attachment #8802578 - Flags: feedback?(ajones) → feedback+
Duplicate of this bug: 1300633
platform-rel: --- → +
Whiteboard: [platform-rel-Netflix]
Should this be uplifted to 51 along with bug 1267495? Or are we ok with aiming this fix at 52? Thanks.
Flags: needinfo?(dale)
I just got asked to work on this so I dont know how high priority it is to ship. I dont think it is hugely risky but not sure about whether its worth uplifting or best to let it do its job and ride the trains.
Flags: needinfo?(dale)
Anthony, what do you think? We do have a longer than usual beta cycle.
Flags: needinfo?(ajones)
I'm in favour of uplifting this group of bugs (relating to bug 1267495) into 51. It will relieve the pain for people currently shooting themselves in the foot with spyware.
Flags: needinfo?(ajones)
For now I'll track this for 51. Gerry, if we take this in 51 we will need to comb through the dependent buts and see what else needs uplift.
Flags: needinfo?(gchang)
I'll take the inaction here and in bug 1267495 as a "no" for 51 as we are now 2 weeks from release.

Anthony, if you still want to fix this for 51 can you find someone to round up whatever needs uplift, and get them to request it on the relevant bugs? Thanks.
Blocks: 1306516
Flags: needinfo?(gchang)
You need to log in before you can comment on or make changes to this bug.