[e10s] CSS "display: none;" not working on <option> elements

RESOLVED FIXED in Firefox 52

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: cillosis, Assigned: Neil Deakin)

Tracking

(Blocks: 1 bug)

49 Branch
mozilla52
x86_64
Windows 7
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8800343 [details]
2016-10-12 14_02_23-Edit fiddle - JSFiddle.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36

Steps to reproduce:

With a fresh install of version 49.0.1, view this JS fiddle: https://jsfiddle.net/e6q96zva/6/


Actual results:

The dropdown will show both the visible and hidden <option> elements, despite CSS being applied to completely hide it.

For a coworker, it worked just fine though in his Firefox (same version) and we determined through experimentation that me installing the "Classic Theme Restorer" Add-On (https://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/) will make the CSS parse correctly again. Disabling the add-on returned it back to the broken state.

A few oddities observed:

- When my coworker disables the add-on, his still works correctly. It appears this may be due to one or more other plugins/add-ons he has installed.

- If I use javascript (uncomment the blurb in the fiddle), it WILL work.


Expected results:

The expectation is the <option> tag will not be rendered when "display: none;" CSS is applied.
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
it's e10s only issue, related to bug 910022.
Blocks: 1154677
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Form Controls
Ever confirmed: true
Product: Firefox → Core
See Also: → bug 910022
Summary: CSS "display: none;" not working on <option> elements → [e10s] CSS "display: none;" not working on <option> elements
(Assignee)

Comment 2

a year ago
The computed display should be used in SelectContentHelper.jsm
(Assignee)

Comment 3

a year ago
Created attachment 8802665 [details] [diff] [review]
Use computed display
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
(Assignee)

Updated

a year ago
Attachment #8802665 - Flags: review?(felipc)
Attachment #8802665 - Flags: review?(felipc) → review+
(Assignee)

Comment 4

a year ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/77b45a6a8309c54549223ab570017585b2fa0283
Bug 1309652, use computed display when determining option display values, r=felipe

Comment 5

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/77b45a6a8309
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-firefox52: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.