Crash in mozilla::a11y::DocAccessible::UncacheChildrenInSubtree

RESOLVED FIXED

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: esthermonchari, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression, regressionwindow-wanted})

52 Branch
Unspecified
Windows
crash, regression, regressionwindow-wanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 wontfix, firefox-esr45 wontfix, firefox50 wontfix, firefox51 wontfix, firefox52+ wontfix, firefox-esr52 fixed, firefox53+ wontfix, firefox54 fixed, firefox55 fixed)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-4dd439a5-1064-416e-9efc-00fee2160928
=============================================================

Crash stated with build id 20160927030200 and is still continuing.

Adding ni on :Alexander and Ehsan since it appears they've worked in that area,  maybe they can help figure out if I placed this in the right component.
Flags: needinfo?(surkov.alexander)
Flags: needinfo?(ehsan)
This is the right component, thanks for the bug report.
Flags: needinfo?(ehsan)
is regression bug known?
Flags: needinfo?(surkov.alexander)
Adding some keywords to get some traction on finding the regression window.
Keywords: regression, regressionwindow-wanted
Crash volume for signature 'mozilla::a11y::DocAccessible::UncacheChildrenInSubtree':
 - nightly (version 52): 29 crashes from 2016-09-19.
 - aurora  (version 51): 80 crashes from 2016-09-19.
 - beta    (version 50): 26 crashes from 2016-09-20.
 - release (version 49): 427 crashes from 2016-09-05.
 - esr     (version 45): 53 crashes from 2016-07-25.

Crash volume on the last weeks (Week N is from 10-17 to 10-23):
            W. N-1  W. N-2  W. N-3  W. N-4
 - nightly       7      13       6       2
 - aurora       28      29      14       2
 - beta          5       7       9       1
 - release     113     134     125      21
 - esr           1       1       0       3

Affected platform: Windows

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly #188      #256
 - aurora  #41
 - beta    #1436
 - release #515
 - esr     #5720
status-firefox49: --- → affected
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox-esr45: --- → affected
status-firefox49: affected → wontfix
Marco have you ever hit this? Would be great to get STR.
Flags: needinfo?(mzehe)
(In reply to David Bolter [:davidb] from comment #5)
> Marco have you ever hit this? Would be great to get STR.
Unfortunately not! I would have either filed it myself if I had, or commented here with a link to my report and a description of the situation this occurred in. :(
Flags: needinfo?(mzehe)
we are a week away from RC, too late, this is now a wontfix for 50. Also, this is a very low volume crash on Beta50 cycle.
status-firefox50: affected → wontfix
Hi David,
It seems to me that the crash starts to show from 51.0b6. Can you help find someone to look at this?
Flags: needinfo?(dbolter)
might have same reasons as bug 1321384 has

I'm curious, if bug 1316789 landing has any correlations with the crash ratio?
(In reply to alexander :surkov from comment #9)
> might have same reasons as bug 1321384 has
> 
> I'm curious, if bug 1316789 landing has any correlations with the crash
> ratio?

Yes I think it roughly doubled. Do you have a hypothesis?
Flags: needinfo?(dbolter) → needinfo?(surkov.alexander)
(In reply to David Bolter [:davidb] from comment #10)
> (In reply to alexander :surkov from comment #9)
> > might have same reasons as bug 1321384 has
> > 
> > I'm curious, if bug 1316789 landing has any correlations with the crash
> > ratio?
> 
> Yes I think it roughly doubled. Do you have a hypothesis?

I would expect it helping rather than aggravating it.

It's interesting the bug was presented in 45.5.1esr only and starting from 50.0.1 (no 46-49). Is there any chance that some changes backported from 50/51 to 45esr increased the crash ratio?

Also 51b/51 crash number increased comparing to 50, which should mean that 51b/51 got some destabializing extras.
Flags: needinfo?(surkov.alexander)
note, bug 1321384 also starts its story from  50.1.0. It'd be interesting to investigate the list of a11y changes made between 49 and 50 (presumably we've got a crash signature in 50) and between 50 and 51 (crash ratio had increased).
In regards to the tracking flags I see that the version is 52 but 51 is shown as affected. Can someone with history of this issue fix that? Thanks
(In reply to Justin [:JW_SoftvisionQA] from comment #13)
> In regards to the tracking flags I see that the version is 52 but 51 is
> shown as affected. Can someone with history of this issue fix that? Thanks

According to the crash stats signature, http://bit.ly/2jEnv3T, 51 is affected.
status-firefox51: affected → wontfix
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox-esr45: affected → wontfix
3232 crashes in the last 7 days on release - this is the #7 overall browser crash.
I'm getting certain that it has same roots as bug 1321384 has. Let's keep tracking of these two bugs in a bunch.
OK, thank.  if that works then we should see this signature drop off in beta 7 later this week.
tracking-firefox52: --- → +
tracking-firefox53: --- → +
This is still around in b7 and b8, no noticeable drop since previous betas afaict.
Not a huge volume and we're getting close to 52 RC → wontfix.
status-firefox52: affected → wontfix
Wontfix for 53 as well. There are still some crashes on 52 and 53, none so far on 54/55.
status-firefox53: affected → wontfix
status-firefox54: affected → fix-optional
status-firefox54: fix-optional → fixed
status-firefox55: --- → fixed
status-firefox-esr52: --- → fixed
You need to log in before you can comment on or make changes to this bug.