Stop using chrome urls in inspector stylesheets

RESOLVED DUPLICATE of bug 1311541

Status

defect
RESOLVED DUPLICATE of bug 1311541
3 years ago
10 months ago

People

(Reporter: jdescottes, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox52 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Blocking Bug 1291049.

To enable images from stylesheets when loading the inspector in html, the stylesheets used by the inspector should not rely on chrome URLs.
Comment hidden (mozreview-request)

Comment 2

3 years ago
mozreview-review
Comment on attachment 8801342 [details]
Bug 1310337 - remove chrome urls from inspector stylesheets;

https://reviewboard.mozilla.org/r/86122/#review84726

Clearing until the test issue I mentioned on IRC is fixed.
Attachment #8801342 - Flags: review?(ntim.bugs)

Updated

3 years ago
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Iteration: --- → 52.2 - Oct 17
Flags: qe-verify?
Priority: -- → P1
Whiteboard: [devtools-html]
(Reporter)

Comment 3

3 years ago
While related to loading the inspector in a content tab, the impact of this bug is that images won't be displayed, but technically it doesn't prevent using the inspector.

After reviewing the remaining bugs I still have to log, I think we should put this one in the reserve. Unassigning myself at the moment.
Assignee: jdescottes → nobody
Status: ASSIGNED → NEW
Priority: P1 → P3
Whiteboard: [devtools-html] → [reserve-html]
Iteration: 52.2 - Oct 17 → ---
(Reporter)

Comment 4

3 years ago
Summary of our conversion on IRC. With the patch attached here the test at browser/base/content/test/general/browser_parsable_css.js will fail. 

We already have some images loaded via relative URLs in our stylesheets which are whitelisted in this test.
See the discussion in Bug 1302708 for hints at how to handle this (load & package the images as resources apparently).

The end goal of this bug remains to be able to have images when using the inspector in a content tab. If another solution (let the development server rewrite the stylesheet dynamically?) seems more appropriate and less impacting for the "real" devtools, we should also consider it.
(Reporter)

Updated

3 years ago
Depends on: 1311541
Priority: P3 → P2
Whiteboard: [reserve-html] → [devtools-html]
(Reporter)

Comment 5

3 years ago
This will be fully handled by Bug 1311541.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1311541
(Reporter)

Updated

3 years ago
No longer depends on: 1311541
No longer blocks: devtools-html-phase2
Flags: qe-verify?
Priority: P2 → --
Whiteboard: [devtools-html]

Updated

10 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.