Hardware video acceleration is not used by Firefox

RESOLVED DUPLICATE of bug 1305107

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1305107
a year ago
a year ago

People

(Reporter: Hristo, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

Open video in HD resolution


Actual results:

Playback is chopped and out of sync


Expected results:

Smooth playback
(Reporter)

Comment 1

a year ago
Example URL:
https://mva.microsoft.com/en-US/training-courses/running-linux-in-microsoft-azure-14738
From task manager it looks that video playback is using a lot of CPU
(Reporter)

Comment 2

a year ago
Hardware is Acer Aspire One 722
CPU: AMD C60
Video Card: AMD Radeon HD6290
RAM: 4G
OS: Windows 10 home version 1607
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Comment 3

a year ago
WFM with FF49 on Win 7.

Could you type about:support in the location bar and copy here the "graphics" section.
Flags: needinfo?(foxb)
(Reporter)

Comment 4

a year ago
Features
Compositing	Direct3D 11
Asynchronous Pan/Zoom	none
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon HD 6290 Graphics Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding	No; Hardware video decoding disabled or blacklisted
Direct2D	true
DirectWrite	true (10.0.14393.321)
GPU #1
Active	Yes
Description	AMD Radeon HD 6290 Graphics
Vendor ID	0x1002
Device ID	0x9807
Driver Version	15.201.1151.0
Driver Date	8-21-2015
Drivers	aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Subsys ID	05981025
RAM	256
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	cairo
failures	[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(20,24000) Code: 0x80070057 format 0
Failure Log
(#0) Error	[D2D1.1] 4CreateBitmap failure Size(20,24000) Code: 0x80070057 format 0
(#1) Error	[D2D1.1] 4CreateBitmap failure Size(20,24000) Code: 0x80070057 format 0
(#2) Error	[D2D1.1] 4CreateBitmap failure Size(20,24000) Code: 0x80070057 format 0
(#3) Error	[D2D1.1] 4CreateBitmap failure Size(20,24000) Code: 0x80070057 format 0
Flags: needinfo?(foxb)

Comment 5

a year ago
If you downgrade to FF48, is hardware video decoding turned on again?
http://ftp.mozilla.org/pub/firefox/releases/48.0.2/win32/
Flags: needinfo?(foxb)

Comment 6

a year ago
In fact, your issue is a duplicate of bug 1305107. You have the same AMD GPU Radeon HD 6000 series with almost the same driver version which is blacklisted by Firefox now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(foxb)
Resolution: --- → DUPLICATE
Duplicate of bug: 1305107
You need to log in before you can comment on or make changes to this bug.