Intermittent devtools/client/webconsole/test/browser_webconsole_autocomplete_popup_close_on_tab_switch.js | Test timed out -

RESOLVED DUPLICATE of bug 1307347

Status

defect
P3
normal
RESOLVED DUPLICATE of bug 1307347
3 years ago
Last year

People

(Reporter: intermittent-bug-filer, Assigned: gbrown)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell fixed])

Attachments

(1 attachment)

Priority: -- → P3
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Assignee

Comment 5

2 years ago
This is e10s-only, multiple platforms.

09:21:04     INFO - TEST-START | devtools/client/webconsole/test/browser_webconsole_autocomplete_popup_close_on_tab_switch.js
09:21:50     INFO - TEST-INFO | started process screencapture
09:21:50     INFO - TEST-INFO | screencapture: exit 0
09:21:50     INFO - Buffered messages logged at 09:21:04
09:21:50     INFO - Entering test bound 
09:21:50     INFO - Buffered messages logged at 09:21:06
09:21:50     INFO - Waiting for event: 'popup-opened' on [object Object].
09:21:50     INFO - Got event: 'popup-opened' on [object Object].
09:21:50     INFO - Buffered messages finished
09:21:50     INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/browser_webconsole_autocomplete_popup_close_on_tab_switch.js | Test timed out - 

Screenshots show 3 tabs open, with "testing autocomplete closes" in the selected tab, so it looks like the test hangs around https://dxr.mozilla.org/mozilla-central/rev/71224049c0b52ab190564d3ea0eab089a159a4cf/devtools/client/webconsole/test/browser_webconsole_autocomplete_popup_close_on_tab_switch.js#24
Comment hidden (Intermittent Failures Robot)
this is high frequency for the last two weeks, in fact it started up again on Jan 24th, I am doing some retriggers to see if I can find a commit that caused this to start up again:
https://treeherder.mozilla.org/#/jobs?repo=autoland&filter-searchStr=linux%20debug%20devtools-chrome-e10s-9&tochange=d7c0d2ef9e102ac48c8466de535131d626dcb030&fromchange=2b6b52a85c6550c2fb1b1c1337facb8edb8f8a8b

ni myself to follow up after the retriggers
Flags: needinfo?(jmaher)
:pbro- reaching out to you as :bgrins is afk- more of a heads up to help find someone to look at this if there is time- I will try to narrow this down a bit more.
Flags: needinfo?(jmaher) → needinfo?(pbrosset)
leave a ni for me
Flags: needinfo?(jmaher)
Assignee

Comment 10

2 years ago
(In reply to Geoff Brown [:gbrown] from comment #5)
> Screenshots show 3 tabs open, with "testing autocomplete closes" in the
> selected tab, so it looks like the test hangs around
> https://dxr.mozilla.org/mozilla-central/rev/
> 71224049c0b52ab190564d3ea0eab089a159a4cf/devtools/client/webconsole/test/
> browser_webconsole_autocomplete_popup_close_on_tab_switch.js#24

See also https://bugzilla.mozilla.org/show_bug.cgi?id=1307347#c38 -- I'm starting to think there is a chance of a hang in loadTab()...might explain why there are lots of webconsole "Test timed out" bugs. Should these tests be using something from BrowserTestUtils instead?
sadly my retriggers didn't surface any other instances of this- maybe we should wait a week in case this isn't so severe, cancelling the ni for now.
Flags: needinfo?(pbrosset)
Flags: needinfo?(jmaher)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
coming back to this bug, it is still failing quite often (20% of the time).

:pbro, I know we had trouble reproducing this on try, do you have other thoughts?
Flags: needinfo?(pbrosset)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
I know :pbro is on pto and there is a backlog of tests that need attention, lets disable for now until we can figure this out, I did find bug 1112599 for tracking disabled webconsole devtools tests which has a few others as well.
Attachment #8840420 - Flags: review?(gbrown)
Assignee

Comment 22

2 years ago
Comment on attachment 8840420 [details] [diff] [review]
disable test on e10s only

Review of attachment 8840420 [details] [diff] [review]:
-----------------------------------------------------------------

Although this test is overdue for disabling, let's hold off. I believe it has the same cause as bug 1307347, which just landed; there are signs this bug is fixed and can be duped to 1307347. (I'll wait another day or two, and check OF, before duping).
Attachment #8840420 - Flags: review?(gbrown) → review-
Assignee

Updated

2 years ago
Assignee: nobody → gbrown
Flags: needinfo?(pbrosset)
Assignee

Comment 23

2 years ago
No failures today or yesterday - I'm convinced.
Status: NEW → RESOLVED
Closed: 2 years ago
Keywords: leave-open
Resolution: --- → DUPLICATE
Duplicate of bug: 1307347
Whiteboard: [stockwell fixed]
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

Updated

Last year
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.