Closed Bug 1310633 Opened 5 years ago Closed 4 years ago

The new location bar's results are blocked by the e10s spinner.

Categories

(Firefox :: Extension Compatibility, defect)

defect
Not set
major

Tracking

()

RESOLVED INVALID

People

(Reporter: dqeswn, Unassigned)

References

(Blocks 1 open bug)

Details

With the new location bar the results are not shown when the in-content e10s spinner is present. Giving the impression that the new location bar is much slower with huge lag.

The location bar is part of the UI, so I don't see why should it wait for the content. The old location bar is totally unaffected.
The only possibility would be that the main-thread is busy waiting for the content process to reply to a synchronous message. That can definitely happen, but it can happen for every operation keeping the main-thread busy, like synchronous IO, an heavy GC and so on.
And it would also happen for the old awesomebar. There is no reason I may think of there should be a difference here. There is nothing in the awesomebar code crossing the e10s boundary.
How can you tell that the old awesomebar was unaffected since we don't have it in the product anymore? If you tested an old version with the old awesomebar, are you sure e10s was enabled?

As it is, I don't see how this would be actionable. Anything blocking the main-thread blocks any feature.
(In reply to Marco Bonardo [::mak] from comment #1)
> How can you tell that the old awesomebar was unaffected since we don't have
> it in the product anymore? If you tested an old version with the old
> awesomebar, are you sure e10s was enabled?

Well, for one it never bothered me with the old urlbar.

I also fired up my test profile with FF47. Started loading a bunch of pages, then opened a new tab, then started typing. The results were present constantly. And I saw the spinner and the results together.
Meanwhile with mozilla central the urlbar results and the spinner seem mutually exclusive. When the spinner appears the results disappear. (Or don't appear at all.)
(In reply to avada from comment #2)
> Well, for one it never bothered me with the old urlbar.

The fact is that the new urlbar and e10s have basically been presented in the same timeframe.

> I also fired up my test profile with FF47.

With E10s enabled?
(In reply to Marco Bonardo [::mak] from comment #3)
> (In reply to avada from comment #2)
> 
> > I also fired up my test profile with FF47.
> 
> With E10s enabled?

Yes.

> The fact is that the new urlbar and e10s have basically been presented in
> the same timeframe.
> 

Well, I've been force-enabling e10s when I was on stable in the past year or two.
It looks like it's caused by the "Remove 'Search with...' and 'Visit' items (if present)" feature of the Classic Theme Restorer addon. Disabling that feature, makes this not happen.

I guess it will be solved by Bug 1235397 if it ever gets implemented.
Component: Location Bar → Extension Compatibility
Depends on: 1235397
With WebExtensions being the only valid way of doing extensions in Firefox 57, I don't think this bug is still relevant.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.