Closed Bug 1311049 Opened 4 years ago Closed 4 years ago

Rename unifiedcomplete tests to follow the same naming convention

Categories

(Toolkit :: Places, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: mattw, Assigned: mattw, Mentored)

References

Details

(Whiteboard: [good first bug][lang=js])

Attachments

(1 file)

It looks like the predominant naming convention used is lowercase_with_underscores.

Therefore, the following tests should be renamed:
 - test_queryurl.js (should be test_query_url.js)
 - test_remotetabmatches.js (should be test_remote_tab_matches.js)
 - test_searchSuggestions.js (should be test_search_suggestions.js)
 - test_tabmatches.js (should be test_tab_matches.js)
 - test_visiturl.js (should be test_visit_url.js)
 - test_searchSuggestions.js (should be test_search_suggestions.js)
 - test_searchEngine_alias.js (should probably be test_search_engine_alias.js)
 - test_searchEngine_current.js (should probably be test_search_engine_current.js)
 - test_searchEngine_host.js (should probably be test_search_engine_host.js)
 - test_searchEngine_restyle.js (should probably be test_search_engine_restyle.js)
 - test_autoFill_default_behavior.js (should probably be test_autofill_default_behavior.js)
while I'm not against doing this, why should we spend time on it? is this a bug you would like to mentor?
Matthew filed this bug after I asked him to add an underscore to the name of his new test or make it camel case, to make it easier to read, in bug 1267810.  I forgot that we had other tests like "tabmatches" and "remotetabmatches", and he had named his test in a similar fashion.

I agree it's a "I'm not against it but it's not important" kind of thing.
oh well. let's just mentor this.
Mentor: mak77
Priority: P2 → P5
Whiteboard: [good first bug][lang=js]
Component: Location Bar → Places
Product: Firefox → Toolkit
I needed a break so I went ahead and made the updates - it took about 5 minutes and I think it's nice to have the consistency.
Comment on attachment 8802225 [details]
Bug 1311049 - Rename unifiedcomplete tests to follow the same naming convention

https://reviewboard.mozilla.org/r/86690/#review85824

thanks
Attachment #8802225 - Flags: review?(mak77) → review+
Assignee: nobody → mwein
Keywords: checkin-needed
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e35c6a772ec4
Rename unifiedcomplete tests to follow the same naming convention r=mak
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e35c6a772ec4
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Depends on: 1353538
You need to log in before you can comment on or make changes to this bug.