try, macosx64 --artifact: mozbuild.configure.options.InvalidOptionError: CC=/builds/slave/try-m64-0000000000000000000000/build/src/clang/bin/clang is not available in this configuration

RESOLVED FIXED in Firefox 52

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: maja_zf, Assigned: chmanchester)

Tracking

(Blocks 1 bug)

unspecified
mozilla52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment)

Flags: needinfo?(mh+mozilla)
Bug 1311069 should take care of this.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1311069
The same errors are present on macos64 after Bug 1311069 has landed.

There are also Windows failures (in original try push in Comment 0 as well), but I will file a separate bug for that.
Status: RESOLVED → REOPENED
Flags: needinfo?(mh+mozilla)
Resolution: DUPLICATE → ---
Oh, we should probably unset CC/CXX like we do for the linux artifact mozconfig...
Assignee: nobody → cmanchester
Flags: needinfo?(mh+mozilla)
Comment hidden (mozreview-request)

Comment 5

3 years ago
mozreview-review
Comment on attachment 8803128 [details]
Bug 1311431 - Unset CC/CXX for Mac artifact mozconfigs.

https://reviewboard.mozilla.org/r/87360/#review86560
Attachment #8803128 - Flags: review?(armenzg) → review+

Comment 6

3 years ago
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9eab2642989d
Unset CC/CXX for Mac artifact mozconfigs. r=armenzg

Comment 7

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9eab2642989d
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.