openerTabId not present in tabs.Tab for tab opened from another one

RESOLVED DUPLICATE of bug 1238314

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1238314
2 years ago
2 years ago

People

(Reporter: sblask, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160920074044

Steps to reproduce:

I tried https://github.com/mdn/webextensions-examples/tree/master/tabs-tabs-tabs and more specifically the `Alert active tab info` on a tab that was opened by clicking on a link in another tab without closing that one.


Actual results:

openerTabId was not present in the list of properties


Expected results:

openerTabId should have been one of the properties and should have been the ID of the tab in which the link was clicked.

Comment 1

2 years ago
Did you try in the latest firefox nightly?
(Reporter)

Comment 2

2 years ago
Yes. Firefox 52.

Updated

2 years ago
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1238314
(Reporter)

Comment 4

2 years ago
Something wrong with the search? I did look for openerTabId before opening this bug and couldn't find anything.
That term only appears in comments, not the summary.
You need to log in before you can comment on or make changes to this bug.