Improve visual difference for unread or watched threads

RESOLVED DUPLICATE of bug 127692

Status

enhancement
RESOLVED DUPLICATE of bug 127692
18 years ago
11 years ago

People

(Reporter: fbonny, Assigned: naving)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

18 years ago
The unread or watched threads in the news need to be more visible, perhaps with
a different color. In Outlook, there's a filter so that a participation to a
thread marks it as watched and when a reponse appears, the group and the thread
is in a different color. It's really useful when you need a hand in an urgent
work. Especially when there's a lot of threads in the group.

Comment 1

18 years ago
And it would be great to have /filters/ in order to mark threads.

A /score/ file like in Xnews, for example :->)

Comment 2

18 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
What do you mean by popular vote ? ;-)

How many votes for it ? Only 3 ?

Is this a popular and important vote ? ;-)))))

By the way, having a score like in XNews should make Messenger the /killer/
newsreader :-)

Updated

18 years ago
Severity: normal → enhancement
Reporter

Comment 4

18 years ago
In fact, it's the only reason for me to use OE. Mozilla is THE browser now and
need a real mail & news module to be THE communication suite. It's really
important to filter posts by subject or keyword when you spend time on newsgroups.

Comment 5

18 years ago
This bug seems to be about marking watched and unread threads.

Newsgroup killfiles and scoring are separate issues entirely.

Comment 6

18 years ago
This bug really seems to be ultimately based on having filters implemented for
newsgroups...bug 17483
Reporter

Comment 7

18 years ago
My idea creating this bug was a little larger than implementing filters only.
With my actuel reader (OE), I can *automatically* mark (label) a thread as
watched if I participate or ignore one posted by someone in my kill-file.
Mozilla is able to do that for Mail (filters & kill) but not for News. Or did I
miss something ?
Target Milestone: --- → mozilla1.0

Comment 8

18 years ago
*** Bug 131579 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
Please update this bug with an [adt1] - [adt3] impact rating (or take it off the
list if it doesn't even rate adt3.)  Thanks!

Comment 10

17 years ago
fbonny: Don't touch the Target Milestone field unless you want to fix this bug
yourself. That field is for the bug owner. To nominate a bug for a certain
release, add a keyword.
OS: Windows 98 → All
Hardware: PC → All
Target Milestone: mozilla1.0 → ---
Reporter

Comment 11

17 years ago
Uh, I can't remember that I've done such a thing ?! If I did, it wasn't my
intention.
Sorry.

Comment 12

17 years ago
You did at 2002-03-16 04:06:06, according to
<http://bugzilla.mozilla.org/show_activity.cgi?id=131164>. It's okay, just be
more careful in the future :-)
This is a dupe of bug 127692.

Comment 14

17 years ago
Nope. Bug 127692 is about the folder pane; this bug is about the threads themselves.

Updated

17 years ago
Depends on: killfile

Comment 15

17 years ago
Should this bug get fixed for 1.0.1 ? Or 1.0.2 ?

It would be a great thing, and give to this *censored* MS Outlook Express a big
kick in its ass :-)

Comment 16

17 years ago
I want this kind of capability at thread in Mail,
if it has a message flagged or marked.

Currently, thread which have unread message is 
displayed with underline.
This is nice.

One suggestion for thread which have flagged message
is to show another bitmap (ex. small flag) in flag column.

Comment 17

17 years ago
See also Bug 122908

Comment 18

17 years ago
Is any work being done on this at the moment?  It sure would be nice to have
this kind of ease of use in the next milestone.

Comment 19

17 years ago
It is in trunk builds. See bug 17483 for more info.

Comment 20

17 years ago
bug 127692 is about making the thread pane behave like the folder pane.

i don't see anything special about this bug, there isn't a spec, there aren't
even proposals. i'm killing it. if you object to my killing then please start a
thread in a newsgroup (npm.mail-news?) where people can discuss what this bug
means. when there's a clear explanation of what this bug wants and an
explanation about how it is distinct from bug 127692 then someone is welcome to
reopen it.

there's certainly no work being done on this bug at the moment. fwiw i'm
considering doing work on filtering in general, but first i'm triaging the
component.

*** This bug has been marked as a duplicate of 127692 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE

Comment 21

16 years ago
I presume you've actually read the message I posted half a month ago in
compliance with your request?
For those who disagreed with timeless' duping, the problem originally addressed
by this bug has resurfaced as bug 164081.  Move your votes, but don't expect it
to be fixed (see my comment there).
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.