Large Download panel after clearing preview panel

RESOLVED WORKSFORME

Status

()

Firefox
Downloads Panel
RESOLVED WORKSFORME
9 months ago
9 months ago

People

(Reporter: bogdan_maris, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 affected, firefox52 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
Created attachment 8802876 [details]
Screenshot showing the issue

[Affected versions]:
- latest Developer Edition 51.0a2
- latest Nightly 52.0a1

[Affected platforms]:
- Windows 8.1 64-bit
- Mac OS X 10.12

[Steps to reproduce]:
1. Start Firefox
2. Download a file (ex: http://www.thinkbroadband.com/download.html)
3. Click "Download Panel"
4. Click "Show All Downloads"
5. Right click on downloaded item
6. Select Show in Finder/Open Containing Folder
7. Delete downloaded item from drive
8. Click "Download Panel"
9. Right click on downloaded item
10. Select "Clear Preview Panel"

[Expected result]:
- Download Panel shrinks to default state when no downloaded items are shown.

[Actual result]:
- Download Panel maintains the same width as having downloaded in panel.

[Additional notes]:
- Screenshot with the issue attached.
bug 1292345 indicates the similar issue for the height of Downloads Panel.
See Also: → bug 1292345
I will return with the pushlog  ASAP.

Comment 3

9 months ago
I cannot reproduce this on Mac OS X 10.9 with the latest Nightly, after following all the steps.

For the platforms on which you reproduced the bug, are steps 3 to 7 really necessary?

Can you identify the bug that introduced this regression?
Flags: needinfo?(cristian.comorasu)
We tried to reproduce this issue on several environments using both the latest nightly and the nightly from the date the bug was logged, this issue is no longer reproducible. Based on this I will close this bug as works for me. 
However if this issue resurfaces please reopen the bug.

Thank you!
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(cristian.comorasu)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.