Closed Bug 1311671 Opened 4 years ago Closed 3 years ago

Download panel glitches after clearing downloads from Library

Categories

(Firefox :: Downloads Panel, defect, P5)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox49 --- unaffected
firefox50 --- affected
firefox51 --- affected
firefox52 --- affected
firefox55 --- verified

People

(Reporter: ccomorasu, Unassigned)

References

Details

Attachments

(1 file)

Attached image Library glitch.gif
[Affected versions]:

 Fx51.0a2
 Fx52.0a1

[Affected platforms]:

 Windows 10 x64
 Windows 8.1 x64
 Mac OS X 10.11
 Ubuntu 14.04 LTS
 
[Steps to reproduce]:

 1. Launch Firefox.
 2. Go to " http://www.thinkbroadband.com/download.html ".
 3. Download 5 files.
 4. Open the Download Panel and click "Show all downloads".
 5. Cancel the downloads (if any) and click on "Clear all downloads".
 6. Close the Library and open the Download Panel.

[Expected result]:

 The download panel opens accordingly.

[Actual result]:

 The download panel glitches.
Will be fixed by 1009116, should be verified once that bug lands.
Depends on: 1009116
Priority: -- → P5
[Regression Range]:

 Last good: 20161019084923 (Fx49.0.2)

 First bad: 20160920155715 (Fx50.0b1)

I will return ASAP with the pushlog.
Duplicate of this bug: 1346871
Hi everyone, please note that I have found a different behavior using 54.0b4 (Build Id:20170501133120) on Ubuntu 16.04 32bit. 

It can be observed that,after following the up mentioned repo steps (from the bug’s summary), the Download Panel (sometimes) remains stretched.

Please observe the following video for more info: https://drive.google.com/open?id=0B94iuIVMr-TEUkUwR0JEc0tlSkk
Grover, can you verify that this is fixed by bug 1009116?
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(gwimberly)
Resolution: --- → FIXED
Verified on Windows, Mac, and Ubuntu. 

Also can no longer replicate the issue in Comment 4, either.
Status: RESOLVED → VERIFIED
Flags: needinfo?(gwimberly)
You need to log in before you can comment on or make changes to this bug.